This is a migrated thread and some comments may be shown as answers.

Installation and LiveDemos: unwanted VS2005 message

5 Answers 75 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Eliyahu Goldin
Top achievements
Rank 1
Eliyahu Goldin asked on 19 May 2008, 07:20 AM
Hello,

I installed the RadControls for ASP.NET AJAX on an XP machine with both VS2005 and VS2008 installed with no problems.

On another machine, a Vista Ultimate with VS2008 only, installation produced a Visual Studio 2005 message "Administrator permissions are recommended for running Visual Studio 2005 SP1" with a "Continue" and "Exit Visual Studio" buttons. Since I am not interested in any 2005 stuff on this machine, I clicked "Exit..". The installation completed ok, but now the LiveDemos application is not operational. Trying to run it produces an error "WebDev.WebServer.exe has stopped working". Trying openning the Live Demos solution in VS2008 causes the same VS2005 "Administration permissions..." message as during the installation.

I didn't check if any of new Rad controls work on that Vista machine.

Shall I just re-install the product? Why do I get this VS2005 message if I don't have any VS2005 installed? What will happen if I choose "Continue"?

Thank you



5 Answers, 1 is accepted

Sort by
0
Princy
Top achievements
Rank 2
answered on 19 May 2008, 10:57 AM
Hi,

Go through the following forum link.
WebDev.WebServer.exe has stopped working

Princy.
0
Eliyahu Goldin
Top achievements
Rank 1
answered on 19 May 2008, 06:32 PM
Thank you, this solves the development server part of the problem. The demos still don't run.

I found in the Live Demos folder 3 Web.config files: Web.config, Web.config.Net20 and Web.config.Net35. After my not-so-clean installation Web.Config looked the same as Web.config.Net20 and I replaced it with the one on Web.config.Net35. Now, when I try to open the Live Demo project, the project conversion wizard pops up. Trying just to run the Live Demos causes some odd compilation error.

Looks like I ended up in a mess and need to re-install. My questions remain:

Why does it ask me about the VS2005 SP1 if I don't have any VS2005?

What will happen if I will let installation proceed with 2005? I don't want to mess up my otherwise working VS 2008.
0
Accepted
Lini
Telerik team
answered on 21 May 2008, 10:36 AM
Hi,

The exception when you start the live demos more than once in Windows Vista should be resolved in the SP1 RadControls for ASP.NET AJAX release (2008.01.515). I think that you are still using the 2008.01.415 release and that's why you are still getting the error.

If you will be running the live demos only VS 2008 (.NET 3.5), here is what you should do:

1) go to the C:\Program Files\Telerik\RadControls for ASPNET AJAX Q1 2008\Live Demos\ folder and copy/rename the Web.config.Net35 file to Web.config (remove the old Web.config file).

2) copy all files from C:\Program Files\Telerik\RadControls for ASPNET AJAX Q1 2008\Bin35\ to C:\Program Files\Telerik\RadControls for ASPNET AJAX Q1 2008\Live Demos\Bin\ and choose to overwrite the old ones when prompted.

3) Open Visual Studio 2008 and select the "Open Web Site.." option from the File menu. Paste the location of the Live Demos folder in the open dialog - C:\Program Files\Telerik\RadControls for ASPNET AJAX Q1 2008\Live Demos\.

I think that the RadControlsExamples.sln file is created with VS 2005, which is why you see the upgrade dialog if you try to open it with VS 2008.

Greetings,
Lini
the Telerik team

Instantly find answers to your questions at the new Telerik Support Center
0
Eliyahu Goldin
Top achievements
Rank 1
answered on 21 May 2008, 05:35 PM
This works, thank you!
0
Shadi
Top achievements
Rank 1
answered on 24 Sep 2008, 03:15 PM
This worked for me also
Tags
General Discussions
Asked by
Eliyahu Goldin
Top achievements
Rank 1
Answers by
Princy
Top achievements
Rank 2
Eliyahu Goldin
Top achievements
Rank 1
Lini
Telerik team
Shadi
Top achievements
Rank 1
Share this question
or