This is a migrated thread and some comments may be shown as answers.

Image Editor not alreays work

3 Answers 17 Views
ImageEditor
This is a migrated thread and some comments may be shown as answers.
lan luo
Top achievements
Rank 1
lan luo asked on 14 May 2014, 02:52 PM
Hi Telerik Team,

Our company are using RadEditor and we enabled Image Editor function in Image Manager.

1. We use single web server in our environment, so we use default ImageCacheStorageLocation.
2. we override the Editor's Content Provider, all the files store in db
3. in the same folder, some of images can be displayed in Image Editor popup window but some of them are not
4. If we open an image which can be displayed in Image Editor popup window, we can see there will be 6 requests, the last two requests are images
5. if we open an image which cannot be displayed, we can only see 4 requests.

Do you have any idea why cause this issue and how can we fix it?

You can check the attachment for more details.

Thanks a lot!

Lan

3 Answers, 1 is accepted

Sort by
0
Vessy
Telerik team
answered on 15 May 2014, 02:57 PM
Hi Lan,

Thank you for the detailed explanation. Unfortunately we are not aware of the described behavior therefore I will need more detailed information in order to investigate the case further:
  • Is the issue reproducible in all browsers or just in a specific one?
  • Is the issue reproducible all the time with the same images or it happens sporadically with different ones?
  • What version of the controls is used in your application?
  • Are you able to reproduce the problem in the following online demo: Custom File Dialogs Content Provider? If so, can you provide the steps to reproduce it with?

It would be really helpful if you isolate the problem into a simple fully runnable project and send it so we could examine it on our side.


Looking forward to hearing from,
Vessy
Telerik
 

Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

 
0
lan luo
Top achievements
Rank 1
answered on 15 May 2014, 07:40 PM
Hi Vessy,

Thanks for your reply. Here's the information to answer your questions.

   1. the issue happens on Firebox, Chrome and IE.
   2. the issue is reproducible all the time with the same images
   3. product version : 2013.3.1324.40
   4. I cannot reproduce on online demo site because online demo site stores files in file system.

We have our customized provider to stores files. The issue never happened on file system but it happens on files which store in db. It's hard to create a simple project because it will user our db system. 

Can you send me your email address which I can send you our application link, so you can see what happened there. Is it OK for you?

Thanks a lot for your help!

Lan


0
Vessy
Telerik team
answered on 20 May 2014, 12:19 PM
Hi Lan,

Thank you for the provided information - unfortunately it is still not enough for us to reproduce the issue.

Please, note that the linked by me demo has an implemented DB content provider, so it stores the images into a data base. In case you are not able to reproduce the problem with it, you can try the provider from this KB, which is used in the demo (with the latest version of the controls).

If this does not help in finding the cause of the problem, you can open a formal support ticket and send the desired private information so we can investigate further the case.

Regards,
Vessy
Telerik
 

Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

 
Tags
ImageEditor
Asked by
lan luo
Top achievements
Rank 1
Answers by
Vessy
Telerik team
lan luo
Top achievements
Rank 1
Share this question
or