Error: Web.config registration missing! The Telerik dialogs require a HttpHandler registration in the web.config file

18 posts, 0 answers
  1. Vinoth Arun
    Vinoth Arun avatar
    25 posts
    Member since:
    Aug 2012

    Posted 28 May 2012 Link to this post


    PROBLEM
    Error: Web.config registration missing! The Telerik dialogs require a HttpHandler registration in the web.config file.

    My Web Config;

    <modules runAllManagedModulesForAllRequests="true" >
          <add type="URLRewriter.ModuleRewriter, URLRewriter" name="ModuleRewriter" />
          <add name="RadUploadModule" type="Telerik.Web.UI.RadUploadHttpModule, Telerik.Web.UI" />
        </modules>
        <handlers>
          <remove name="WebServiceHandlerFactory-Integrated" />
          <remove name="ScriptHandlerFactory" />
          <remove name="ScriptHandlerFactoryAppServices" />
          <remove name="ScriptResource" />
          <remove name="ChartImageHandler" />
     
          <add name="Telerik_Web_UI_WebResource_axd" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" />
          <add name="Telerik_Web_UI_DialogHandler_aspx" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler" />
          <add name="Telerik_Web_UI_SpellCheckHandler_axd" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler" />
          <add name="ChartImageHandler" preCondition="integratedMode" verb="GET,HEAD,POST" path="ChartImg.axd" type="System.Web.UI.DataVisualization.Charting.ChartHttpHandler, System.Web.DataVisualization, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
          <add name="ChartImage_axd" verb="*" preCondition="integratedMode" path="ChartImage.axd" type="Telerik.Web.UI.ChartHttpHandler" />
        </handlers>
    <httpHandlers>
          <remove path="*.asmx" verb="*" />
       <add path="Telerik.Web.UI.WebResource.axd" verb="*" type="Telerik.Web.UI.WebResource" validate="false" />
          <add path="Telerik.Web.UI.DialogHandler.aspx" verb="*" type="Telerik.Web.UI.DialogHandler" validate="false" />
          <add path="Telerik.Web.UI.SpellCheckHandler.axd" verb="*" type="Telerik.Web.UI.SpellCheckHandler" validate="false" />
            
        </httpHandlers>
  2. Rumen
    Admin
    Rumen avatar
    13980 posts

    Posted 28 May 2012 Link to this post

    Hi,

    My suggestion is to:
    1. open the web.config file and replace all Telerik.Web.UI.DialogHandler.aspx instances with Telerik.Web.UI.DialogHandler.axd
    2. and set the RadEditor's DialogHandlerUrl property to "~/Telerik.Web.UI.DialogHandler.axd"


    All the best,
    Rumen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  3. Jon
    Jon avatar
    7 posts
    Member since:
    Feb 2014

    Posted 24 Feb 2014 in reply to Rumen Link to this post

    This made me get 404 instead of 403.1
  4. Jon
    Jon avatar
    7 posts
    Member since:
    Feb 2014

    Posted 24 Feb 2014 in reply to Jon Link to this post

    Sorry, I had forgotten to deploy. This works well.
  5. WEBSRFR
    WEBSRFR avatar
    16 posts
    Member since:
    Mar 2004

    Posted 03 Jan 2015 Link to this post

    I just had the same issue with the following error message and I have attached an image of the error message. 

    "Web.config registration missing! The Telerik dialogs require a HttpHandler registration in the web.config file."

    The instructions on the thread saved me as I was able to make the error go away after opening the web.config file and replacing all Telerik.Web.UI.DialogHandler.aspx instances with Telerik.Web.UI.DialogHandler.axd and then setting the RadEditor's DialogHandlerUrl property to "~/Telerik.Web.UI.DialogHandler.axd"

    I am confused why I received this error message though as I have a default and unchanged latest build of the ASP.Net AJAX controls. Is something wrong with my installation that I had to change these settings for the Editor dialogs to work or do these settings need to be changed on every Telerik Controls installation?
  6. Ianko
    Admin
    Ianko avatar
    1886 posts

    Posted 06 Jan 2015 Link to this post

    Hello,

    It depends on the situation. Basically, this happens when the URL (the root path) has been dynamically  changed. For example:

    • Usage of URL rewriter;
    • In SharePoint;
    • In other CMS application.

    Regards,

    Ianko
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  7. WEBSRFR
    WEBSRFR avatar
    16 posts
    Member since:
    Mar 2004

    Posted 06 Jan 2015 in reply to Ianko Link to this post

    This work around is going to become increasingly popular I think because just like Bootstrap, friendly URLs are now becoming a part of default ASP.net projects. Would be great if the next build by default would support Friendly URLs without needing changes.
  8. Ianko
    Admin
    Ianko avatar
    1886 posts

    Posted 08 Jan 2015 Link to this post

    Hi,

    Friendly URL matter is not something that can be enabled or configured when it comes to handlers or requests made by the controls.

    URL rewrites are a matter of application configuration/implementation and it is up to the developer to configure the URL rewriter module to exclude the e.g., *.axd handler requests or any other type of requests that may lead to such problems.

    In the process of controls development, what would be the technique used to intercept a possible URL rewrite and possibly correct it as per to the control needs? Such automatic interaction would be rather faulty as there is no common approach to create friendly URLs, this is rather manually configuration approach which depends on the project and the project's requirements.

    Regards,
    Ianko
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  9. Preksha
    Preksha avatar
    1 posts
    Member since:
    Feb 2017

    Posted 14 Feb 2017 Link to this post

    Recently we upgraded our Sitecore website from 8.0 to 8.2. Previously everything was working fine but after upgrading it started giving error while adding hyperlink in Rich Text Editor. When we click on "Show Editor" of Rich Text Editor and then Hyperlink Manager to add link there is pop up which gives error:

    "Web.config registration missing! The Telerik dialogue requires a HttpHandler registration

  10. Rumen
    Admin
    Rumen avatar
    13980 posts

    Posted 14 Feb 2017 Link to this post

    Hello Preksha,

    Please, report all Sitecore related configuration issues to Sitecore support.

    Regards,
    Rumen
    Telerik by Progress
    Try our brand new, jQuery-free Angular 2 components built from ground-up which deliver the business app essential building blocks - a grid component, data visualization (charts) and form elements.
  11. Ravi
    Ravi avatar
    6 posts
    Member since:
    Jun 2015

    Posted 24 Dec 2018 in reply to Rumen Link to this post

    Hi 

    I am facing a similar issue with RadEditor. Its not working while debugging on local. Here are the settings of Web.Config & RadEdito Control settings. When I click on RadEditor "Paste fromWord, strip font" icon, a Popup is coming which says" local host refused to connect"

      <system.webServer>
        <modules runAllManagedModulesForAllRequests="true">
          <remove name="FormsAuthentication"/>
        </modules>
        <validation validateIntegratedModeConfiguration="false"/>
        <handlers>
          <add name="Telerik_Web_UI_WebResource_axd" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource"/>
          <add name="Telerik_Web_UI_DialogHandler_axd" path="Telerik.Web.UI.DialogHandler.axd" type="Telerik.Web.UI.DialogHandler" verb="*" preCondition="integratedMode"/>
        </handlers>

    ....

      <system.web>
        <httpRuntime maxRequestLength="102400" executionTimeout="3600" targetFramework="4.5" requestValidationMode="4.5"/>
        <httpHandlers>
          <add verb="GET" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler" validate="false"/>
          <add path="Reserved.ReportViewerWebControl.axd" verb="*" type="Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" validate="false"/>
          <add path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" verb="*" validate="false"/>
          <add path="Telerik.Web.UI.DialogHandler.axd" type="Telerik.Web.UI.DialogHandler" verb="*" validate="false"/>
        </httpHandlers>

     

     

         <telerik:RadEditor ID="RadEditor1" runat="server" ShowSubmitCancelButtons="False" DialogHandlerUrl ="~/Telerik.Web.UI.DialogHandler.axd"
                                EnableResize="false" Width="100%"  ToolsFile="~/WebCommon/Inc/_xml/EmailToolsFile.xml"
                                ConvertToXhtml="true" OnClientLoad="util.SetRadEditorColor">
                            </telerik:RadEditor>

    Can you please let me know whats the fix to resolve this?

     

    Regards

    Ravi

     

     

     

     

  12. Attila Antal
    Admin
    Attila Antal avatar
    323 posts

    Posted 27 Dec 2018 Link to this post

    Hi Ravi,

    Based on the screenshot, I assume this issue is seen when using the RadEditor in SharePoint, is that correct? If so, could you share the version of SharePoint as well as the version of Telerik controls used?

    Kind regards,
    Attila Antal
    Progress Telerik
    Get quickly onboarded and successful with your Telerik and/or Kendo UI products with the Virtual Classroom free technical training, available to all active customers. Learn More.
  13. Ravi
    Ravi avatar
    6 posts
    Member since:
    Jun 2015

    Posted 27 Dec 2018 in reply to Attila Antal Link to this post

    Hi Attila ,

     

    No, this is not a sharepoint site. Its a normal Asp.net website.

     

    Regards

    Ravi

  14. Ravi
    Ravi avatar
    6 posts
    Member since:
    Jun 2015

    Posted 27 Dec 2018 in reply to Ravi Link to this post

    Hi Attila 

     

    The Telerik Version I am using is 2018.1.117.45.

    Regards

    Ravi

  15. Ravi
    Ravi avatar
    6 posts
    Member since:
    Jun 2015

    Posted 27 Dec 2018 in reply to Ravi Link to this post

    Hi Attila 

    The Telerik version I am using is 2018.1.117.45.

    Regards

    Ravi

  16. Attila Antal
    Admin
    Attila Antal avatar
    323 posts

    Posted 27 Dec 2018 Link to this post

    Hi Ravi,

    In general, if either the handlers or the httpHandlers were missing/incorrect in the web.config file, you would receive an error message of 404 saying the "The resource cannot be found". The error "localhost refused to connect" seems to be a problem that occurs within Visual Studio. By searching for this specific error, I found that several people recommend deleting the .vs folder within the Project which contains some settings. The file will be re-generated once Visual Studio is opened.

    You may try to move that folder in a safe place and see if that helps. Here is one example: Re: getting error This site can’t be reached localhost refused to connect
    See also: localhost refused to connect Error in visual studio.

    You can also try the following handlers and httpHandlers declarations which work for me (attached you can find the entire project, you can download and test to see if that works):

    httpHandlers
    <httpHandlers>
      <add path="ChartImage.axd" type="Telerik.Web.UI.ChartHttpHandler" verb="*" validate="false" />
      <add path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler" verb="*" validate="false" />
      <add path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler" verb="*" validate="false" />
      <add path="Telerik.RadUploadProgressHandler.ashx" type="Telerik.Web.UI.RadUploadProgressHandler" verb="*" validate="false" />
      <add path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" verb="*" validate="false" />
    </httpHandlers>

    handlers
    <handlers>
      <remove name="ChartImage_axd" />
      <add name="ChartImage_axd" path="ChartImage.axd" type="Telerik.Web.UI.ChartHttpHandler" verb="*" preCondition="integratedMode" />
      <remove name="Telerik_Web_UI_SpellCheckHandler_axd" />
      <add name="Telerik_Web_UI_SpellCheckHandler_axd" path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler" verb="*" preCondition="integratedMode" />
      <remove name="Telerik_Web_UI_DialogHandler_aspx" />
      <add name="Telerik_Web_UI_DialogHandler_aspx" path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler" verb="*" preCondition="integratedMode" />
      <remove name="Telerik_RadUploadProgressHandler_ashx" />
      <add name="Telerik_RadUploadProgressHandler_ashx" path="Telerik.RadUploadProgressHandler.ashx" type="Telerik.Web.UI.RadUploadProgressHandler" verb="*" preCondition="integratedMode" />
      <remove name="Telerik_Web_UI_WebResource_axd" />
      <add name="Telerik_Web_UI_WebResource_axd" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" verb="*" preCondition="integratedMode" />
    </handlers>


    Kind regards,
    Attila Antal
    Progress Telerik
    Get quickly onboarded and successful with your Telerik and/or Kendo UI products with the Virtual Classroom free technical training, available to all active customers. Learn More.
  17. Ravi
    Ravi avatar
    6 posts
    Member since:
    Jun 2015

    Posted 29 Jan in reply to Attila Antal Link to this post

    Hi Attila,

    I looked your code & incorporated the same in my project. Now I am not seeing the dialog box saying" require a Http handler registration" but when i click on option "strip from word, no font" i am still seeing the popup saying "local host refused to connect". I already tried the steps you mentioned in earlier thread but no success.

    For your reference I am attaching a Web.config for the same.

    Can you please let me know where I am doing something wrong.

    I am using the following version: Telerik.Web.UI, Version=2018.1.117.45

    Regards

    Ravi

     

     

    <?xml version="1.0"?>
    <!-- 
        Note: As an alternative to hand editing this file you can use the 
        web admin tool to configure settings for your application. Use
        the Website->Asp.Net Configuration option in Visual Studio.
        A full list of settings and comments can be found in 
        machine.config.comments usually located in  
        \Windows\Microsoft.Net\Framework\v2.x\Config 
    -->
    <configuration>

      <!--
        For a description of web.config changes see http://go.microsoft.com/fwlink/?LinkId=235367.

        The following attributes can be set on the <httpRuntime> tag.
          <system.Web>
            <httpRuntime targetFramework="4.5" />
          </system.Web>
      -->
      <system.web>
        <httpRuntime maxRequestLength="102400" executionTimeout="3600" targetFramework="4.5" requestValidationMode="4.5"/>
        <httpHandlers>
          <add path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler" verb="*" validate="false"/>
          <add path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler" verb="*" validate="false"/>
          <add path="Telerik.RadUploadProgressHandler.ashx" type="Telerik.Web.UI.RadUploadProgressHandler" verb="*" validate="false"/>
          <add path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" verb="*" validate="false"/>
        </httpHandlers>
        <!-- 
                Set compilation debug="true" to insert debugging 
                symbols into the compiled page. Because this 
                affects performance, set this value to true only 
                during development.
            -->
        <compilation debug="true" defaultLanguage="c#" targetFramework="4.7.1">      
          <assemblies>
            <add assembly="System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
            <add assembly="System.IdentityModel, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
            <add assembly="System.IdentityModel.Services, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
          </assemblies>
          <buildProviders>
            <add extension=".rdlc" type="Microsoft.Reporting.RdlBuildProvider, Microsoft.ReportViewer.Common, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
          </buildProviders>
        </compilation>
        <pages controlRenderingCompatibilityVersion="3.5" clientIDMode="AutoID">
          <controls>
            <add tagPrefix="telerik" namespace="Telerik.Web.UI" assembly="Telerik.Web.UI, Version=2018.1.117.45, Culture=neutral, PublicKeyToken=121fae78165ba3d4"/>        
          </controls>
        </pages>
        <sessionState timeout="1440"/>
      </system.web>
      <system.webServer>
        <modules runAllManagedModulesForAllRequests="true">
          <remove name="FormsAuthentication"/>
        </modules>
        <validation validateIntegratedModeConfiguration="false"/>
          <handlers>
            <remove name="ChartImage_axd"/>
            <add name="ChartImage_axd" path="ChartImage.axd" type="Telerik.Web.UI.ChartHttpHandler" verb="*" preCondition="integratedMode"/>
            <remove name="Telerik_Web_UI_SpellCheckHandler_axd"/>
            <add name="Telerik_Web_UI_SpellCheckHandler_axd" path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler" verb="*" preCondition="integratedMode"/>
            <remove name="Telerik_Web_UI_DialogHandler_aspx"/>
            <add name="Telerik_Web_UI_DialogHandler_aspx" path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler" verb="*" preCondition="integratedMode"/>
            <remove name="Telerik_RadUploadProgressHandler_ashx"/>
            <add name="Telerik_RadUploadProgressHandler_ashx" path="Telerik.RadUploadProgressHandler.ashx" type="Telerik.Web.UI.RadUploadProgressHandler" verb="*" preCondition="integratedMode"/>
            <remove name="Telerik_Web_UI_WebResource_axd"/>
            <add name="Telerik_Web_UI_WebResource_axd" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" verb="*" preCondition="integratedMode"/>
        </handlers>
        <httpProtocol>
          <customHeaders>
            <clear/>
            <add name="X-UA-Compatible" value="IE=Edge"/>
            <add name="X-XSS-Protection" value="1"/>
            <add name="X-Frame-Options" value="DENY"/>
          </customHeaders>
        </httpProtocol>
        
      </system.webServer>

      <location path="Telerik.Web.UI.WebResource.axd">
        <system.web>
          <authorization>
            <allow users="*" />
          </authorization>
        </system.web>
      </location>
     
    </configuration>

     

  18. Attila Antal
    Admin
    Attila Antal avatar
    323 posts

    Posted 01 Feb Link to this post

    Hi Ravi,

    I have tested the Web config file you've shared and I found that the following custom header was preventing the RadEditor's Popups to load:

    <add name="X-Frame-Options" value="DENY"/>

    RadEditor highly relies on RadWindows to bring up the tools and some windows may render as an iFrame and if this is blocked, they can't load the content. You can fix the error by commenting out the X-Frame-Options custom header from the web.config file.

    <httpProtocol>
      <customHeaders>
        <clear/>
        <add name="X-UA-Compatible" value="IE=Edge"/>
        <add name="X-XSS-Protection" value="1"/>
        <!--<add name="X-Frame-Options" value="DENY"/>-->
      </customHeaders>
    </httpProtocol>

    I hope this will prove helpful.

    Kind regards,
    Attila Antal
    Progress Telerik
    Get quickly onboarded and successful with your Telerik and/or Kendo UI products with the Virtual Classroom free technical training, available to all active customers. Learn More.
Back to Top