Error registering the viewer with the service

3 posts, 0 answers
  1. Omar
    Omar avatar
    9 posts
    Member since:
    Sep 2016

    Posted 12 Nov 2019 Link to this post

    Hi,

    I am having this error on my page when i try to display the report in the html5 report viewer

    Error registering the viewer with the service.
    An error has occurred.
    Access to the path 'C:\windows\TEMP\Html5DemoApp\12.0.18.416\LCT\value.dat' is denied.

    I have read that is because The error message "Access to the path X is denied" indicates that the Telerik Reporting REST service cannot access the configured file storage. By default, user temp folder will be used as a storage which is 'C:\Windows\TEMP' in this case.

    I read this in the following article:

    https://docs.telerik.com/reporting/knowledge-base/error-registering-the-viewer-with-the-service

    It says that I need to assign default storage location using  ReportsController.cs file where the settings of the Reporting REST service are defined.

    The question is I can not find that file in my solution. How do we do that?

    Regards,

    Omar

  2. Nasko
    Admin
    Nasko avatar
    1071 posts

    Posted 15 Nov 2019 Link to this post

    Hi Omar,

    The ReportsController.cs file is located in the project of your REST WebAPI service project. The project structure should be similar to this project.

    Another option is to search for the file using the search feature of your operating system.

    Regards,
    Nasko
    Progress Telerik

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. Omar
    Omar avatar
    9 posts
    Member since:
    Sep 2016

    Posted 23 Nov 2019 in reply to Nasko Link to this post

    It was not there, But I have created new project with new reports and then I saw the file at the location you specified.

    It seams I have deleted by mistake.

    Many thanks,

    Omar

Back to Top