Edit context menu does not respond

5 posts, 0 answers
  1. David
    David avatar
    17 posts
    Member since:
    Aug 2011

    Posted 01 Apr 2012 Link to this post

    My two RadSchedulers work perfectly on my developer machine within Visual Studio. When I deploy to the production web server, it works all except for one minor difference. Here is what happens accessing my RadSchedulers via our remote web server:
    • A user will right click on an existing appointment (or empty space). This shows the New Appointment / Edit / Delete context menu choices. Click Edit. The New/Edit/Delete menu disappears. (so far so good). But then, nothing happens. The modal default Appointment editor window never appears. No error gets thrown, I don't see any errors in the web browser status bar. I've done this so many times and it never appears, regardless of what appointment in my scheduler that I choose.
    • Same problem for New Appointment. Nothing happens after the context menu disappears.
    • However, if you click Delete, the confirmation window appears: "Are you sure you want to delete this appointment?" . I click OK and it works fine, the appointment gets deleted.

    But for New and Edit, the appointment window won't popup. This happens for all client web browsers, Safari, IE, Chrome. It happens on different client machines and for different users. So it feels like the problem is something on the web server, not a client side problem. Could there be some kind of deployment issue? Something I didn't deploy properly? Is the production web server running a different version of required DLL's?

    This works perfectly on my developer machine within Visual Studio, so I know this should work. I've never had any problems creating or editing appointments when running locally on my test virtual machine developer environment. So I think my aspx and c# code is correct, since it works locally. Another test scenario is from my developer machine, hit the production web site. The same problem occurs. So my developer machine also fails when hitting the production web URL. But not within Visual Studio.

    Thanks for your help.

  2. Plamen
    Plamen avatar
    2810 posts

    Posted 04 Apr 2012 Link to this post

    Hello David,

    This sounds like a very strange behavior indeed that is not known to us by the moment. Would you please share the code that is related with RadScheduler so that we could inspect it locally. Providing a live URL could be helpful as well. 

    Meanwhile I would like to ask you to do several tests and let me know what will be the results. First you can try to change the values of the StartInsertingInAdvancedForm and StartUpdatingInAdvancedForm properties of RadScheduler depending on what are their current values and check if the functionality is working. After that you can check if there is a difference between the behavior with modal and non modal advanced form.

    Plamen Zdravkov
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  3. David
    David avatar
    17 posts
    Member since:
    Aug 2011

    Posted 04 Apr 2012 Link to this post

    I have solved the issue. After finding a more detailed error message on my page (after enabling custom errors in web.config) which was:

    Selection out of range
    Parameter name: value

    Eventually I stumbed upon this thread from just 2 weeks ago:

    Which suggested Telerik was aware of the bug and had fixed it with their hotfix internal build. Applying the latest internal build hotfix for ASP.NET AJAX Q1 2012 sure enough fixed my error too.
  4. Aqeel
    Aqeel avatar
    1 posts
    Member since:
    Feb 2015

    Posted 10 Feb 2015 Link to this post

    I am having the same error When I upload Scheduler to the server edit maneu that appears on double click does not respond not edit not save nothing blank is there any solution...?
  5. Plamen
    Plamen avatar
    2810 posts

    Posted 13 Feb 2015 Link to this post


    The described issue is not a known one and in we will need more information how to replicate it at our side in order to be more helpful.


    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

Back to Top