DotNetNuke & Telerik - ImageManager Not Working

3 posts, 0 answers
  1. Marko
    Marko avatar
    1 posts
    Member since:
    Apr 2011

    Posted 08 Apr 2011 Link to this post

    Hello!

    I have DotNetNuke version 05.06.02 and Telerik version 2011.1.315.35.
    I am making a site that will store the content in the editor to MS SQL and images in the images folder
    but I hit the problem already in the beginning - ImageEditor pops up and is loading and loading for ever.

    I can't find what could be the problem.
    My code:

    KnowledgeBaseAdd.aspx
    <%@ Page Language="C#" AutoEventWireup="true" CodeFile="KnowledgeBaseAdd.aspx.cs" Inherits="DesktopModules_KnowladgeBase_KnowledgeBaseAdd" %>
    <%@ Register Assembly="Telerik.Web.UI" Namespace="Telerik.Web.UI" TagPrefix="telerik" %>
    <%@ Register TagPrefix="dnn" Namespace="DotNetNuke.Web.UI.WebControls" Assembly="DotNetNuke.Web" %>
     
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
     
    <head runat="server">
        <title></title>
    </head>
    <body>
        <form id="form1" runat="server">
        <telerik:RadScriptManager ID="RadScriptManager1" runat="server">
        </telerik:RadScriptManager>
        <div>
            <telerik:RadEditor ID="RadEditor1" runat="server">
            <ImageManager ViewPaths="/" UploadPaths="/" DeletePaths="/" />
            <DocumentManager ViewPaths="/" UploadPaths="/" DeletePaths="/" />
     
            </telerik:RadEditor>
        </div>
        </form>
    </body>
    </html>

    KnowledgeBaseAdd.aspx.cs
    using System;
    using System.Collections.Generic;
    using System.Linq;
    using System.Web;
    using System.Web.UI;
    using System.Web.UI.WebControls;
     
    public partial class DesktopModules_KnowladgeBase_KnowledgeBaseAdd : System.Web.UI.Page
    {
        protected void Page_Load(object sender, EventArgs e)
        {
            string[] imagepath = { "/" };
            string[] documentpath = { "/" };
            RadEditor1.ImageManager.UploadPaths = imagepath;
            RadEditor1.ImageManager.ViewPaths = imagepath;
            RadEditor1.ImageManager.DeletePaths = imagepath;
            RadEditor1.DocumentManager.UploadPaths = documentpath;
            RadEditor1.DocumentManager.ViewPaths = documentpath;
            RadEditor1.DocumentManager.DeletePaths = documentpath;
     
        }
    }

    Since the update of Telerik was done, maybe there is a problem in web.config file but my intuition tells me that that is not the case.
    Web.config:
    <configuration>
        <!-- register local configuration handlers -->
        <configSections>
            <sectionGroup name="dotnetnuke">
                <!-- the requirePermission attribute will cause a syntax warning - please ignore - it is required for Medium Trust support-->
                <section name="data" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke"/>
                <section name="logging" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke"/>
                <section name="scheduling" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke"/>
                <section name="htmlEditor" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke"/>
                <section name="navigationControl" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke"/>
                <section name="searchIndex" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke"/>
                <section name="searchDataStore" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke"/>
                <section name="friendlyUrl" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke"/>
                <section name="caching" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke"/>
                <section name="authentication" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke"/>
                <section name="members" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke"/>
                <section name="roles" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke"/>
                <section name="profiles" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke"/>
                <section name="permissions" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke"/>
                <section name="moduleCaching" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke"/>
                <section name="outputCaching" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke"/>
                <section name="sitemap" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke"/>
            </sectionGroup>
        </configSections>
        <connectionStrings>
            <add name="SiteSqlServer" connectionString="Data Source=fs.fliptest.local;Initial Catalog=helpdesk;User ID=sa;Password=Laskopivo1234" providerName="System.Data.SqlClient"/>
            <add name="uoffice2ConnectionString" connectionString="Data Source=fs.fliptest.local;Initial Catalog=uoffice_dev;User ID=sa;Password=Laskopivo1234" providerName="System.Data.SqlClient"/>
        </connectionStrings>
        <appSettings>
            <!-- Connection String for SQL Server 2005/2008 Express - kept for backwards compatability - legacy modules   -->
            <add key="SiteSqlServer" value="Data Source=fs.fliptest.local;Initial Catalog=helpdesk;User ID=sa;Password=Laskopivo1234"/>
            <!-- Connection String for SQL Server 2005/2008 - kept for backwards compatability - legacy modules
        <add key="SiteSqlServer" value="Server=(local);Database=DotNetNuke;uid=;pwd=;"/>
        -->
            <add key="InstallTemplate" value="DotNetNuke.install.config"/>
            <add key="AutoUpgrade" value="true"/>
            <add key="UseInstallWizard" value="true"/>
            <add key="InstallMemberRole" value="true"/>
            <add key="ShowMissingKeys" value="false"/>
            <add key="EnableCachePersistence" value="false"/>
            <add key="HostHeader" value=""/>
            <!-- Host Header to remove from URL so "www.mydomain.com/johndoe/Default.aspx" is treated as "www.mydomain.com/Default.aspx" -->
            <add key="RemoveAngleBrackets" value="false"/>
            <!--optionally strip angle brackets on public login and registration screens-->
            <add key="PersistentCookieTimeout" value="0"/>
            <!--use as persistent cookie expiration. Value is in minutes, and only active if a non-zero figure-->
            <!-- set UsePortNumber to true to preserve the port number if you're using a port number other than 80 (the standard)
        <add key="UsePortNumber" value="true" />
        -->
            <add key="InstallationDate" value="4/1/2011"/>
        </appSettings>
        <system.codedom>
            <compilers>
                <compiler language="vb;vbs;visualbasic;vbscript" type="Microsoft.VisualBasic.VBCodeProvider, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" extension=".vb" warningLevel="4">
                    <providerOption name="CompilerVersion" value="v3.5"/>
                    <providerOption name="OptionInfer" value="true"/>
                    <providerOption name="WarnAsError" value="false"/>
                </compiler>
                <compiler language="c#;cs;csharp" extension=".cs" type="Microsoft.CSharp.CSharpCodeProvider,System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" warningLevel="4">
                    <providerOption name="CompilerVersion" value="v3.5"/>
                    <providerOption name="WarnAsError" value="false"/>
                </compiler>
            </compilers>
        </system.codedom>
        <!-- The system.webServer section is required for IIS7 compatability It is ignored by IIS6-->
        <system.webServer>
            <modules>
                <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" preCondition="managedHandler"/>
                <add name="Compression" type="DotNetNuke.HttpModules.Compression.CompressionModule, DotNetNuke.HttpModules" preCondition="managedHandler"/>
                <add name="RequestFilter" type="DotNetNuke.HttpModules.RequestFilter.RequestFilterModule, DotNetNuke.HttpModules" preCondition="managedHandler"/>
                <add name="UrlRewrite" type="DotNetNuke.HttpModules.UrlRewriteModule, DotNetNuke.HttpModules" preCondition="managedHandler"/>
                <add name="Exception" type="DotNetNuke.HttpModules.Exceptions.ExceptionModule, DotNetNuke.HttpModules" preCondition="managedHandler"/>
                <add name="UsersOnline" type="DotNetNuke.HttpModules.UsersOnline.UsersOnlineModule, DotNetNuke.HttpModules" preCondition="managedHandler"/>
                <add name="DNNMembership" type="DotNetNuke.HttpModules.Membership.MembershipModule, DotNetNuke.HttpModules" preCondition="managedHandler"/>
                <add name="Personalization" type="DotNetNuke.HttpModules.Personalization.PersonalizationModule, DotNetNuke.HttpModules" preCondition="managedHandler"/>
                <add name="Analytics" type="DotNetNuke.HttpModules.Analytics.AnalyticsModule, DotNetNuke.HttpModules" preCondition="managedHandler"/>
                <add name="RadUploadModule" type="Telerik.Web.UI.RadUploadHttpModule, Telerik.Web.UI" preCondition="managedHandler"/>
            </modules>
            <handlers>
                <remove name="WebServiceHandlerFactory-Integrated"/>
                <add name="LogoffHandler*" path="Logoff.aspx" verb="*" type="DotNetNuke.Services.Authentication.LogOffHandler, DotNetNuke" preCondition="integratedMode"/>
                <add name="RSSHandler" path="RSS.aspx" verb="*" type="DotNetNuke.Services.Syndication.RssHandler, DotNetNuke" preCondition="integratedMode"/>
                <add name="LinkClickHandler" path="LinkClick.aspx" verb="*" type="DotNetNuke.Services.FileSystem.FileServerHandler, DotNetNuke" preCondition="integratedMode"/>
                <add name="CaptchaHandler" path="*.captcha.aspx" verb="*" type="DotNetNuke.UI.WebControls.CaptchaHandler, DotNetNuke" preCondition="integratedMode"/>
                <add name="ScriptHandlerFactory" verb="*" path="*.asmx" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
                <add name="ScriptHandlerFactoryAppServices" verb="*" path="*_AppService.axd" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
                <add name="ScriptResource" verb="GET,HEAD" path="ScriptResource.axd" preCondition="integratedMode" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
                <add name="UserProfilePageHandler" verb="*" path="User.aspx" type="DotNetNuke.Services.UserProfile.UserProfilePageHandler, DotNetNuke" preCondition="integratedMode"/>
                <add name="RadProgressHandler" verb="*" path="Telerik.RadUploadProgressHandler.ashx" type="Telerik.Web.UI.Upload.RadUploadProgressHandler, Telerik.Web.UI" preCondition="integratedMode"/>
          <add name="Telerik.Web.UI.WebResource" verb="*" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource, Telerik.Web.UI"/>
                <add name="Telerik.Web.UI.ChartHttpHandler" verb="*" path="ChartImage.axd" type="Telerik.Web.UI.ChartHttpHandler, Telerik.Web.UI, Culture=neutral, PublicKeyToken=121fae78165ba3d4"/>
                <add name="SitemapHandler" path="Sitemap.aspx" verb="*" type="DotNetNuke.Services.Sitemap.SitemapHandler, DotNetNuke" preCondition="integratedMode"/>
                <add name="HtmTemplateFileHandler" verb="*" path="*.htmtemplate" type="DotNetNuke.HtmlEditor.TelerikEditorProvider.HtmTemplateFileHandler, DotNetNuke.HtmlEditor.TelerikEditorProvider" preCondition="integratedMode"/>
          <add name="Telerik_Web_UI_SpellCheckHandler_axd" path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler" verb="*" preCondition="integratedMode" />
          <add name="Telerik_Web_UI_DialogHandler_aspx" path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler" verb="*" preCondition="integratedMode" />
            </handlers>
            <validation validateIntegratedModeConfiguration="false"/>
        </system.webServer>
        <system.web>
            <machineKey validationKey="94AF4CDE304D971BB94AC5A71CC490ECB525ADF8" decryptionKey="A7B8D0E0036E6AC262CA5CF68D676E79911FDB68359C0E69" decryption="3DES" validation="SHA1"/>
            <!-- HttpModules for Common Functionality -->
            <httpModules>
                <!-- add name="Authentication" type="DotNetNuke.HttpModules.AuthenticationModule, DotNetNuke.HttpModules.Authentication" / -->
                <add name="Compression" type="DotNetNuke.HttpModules.Compression.CompressionModule, DotNetNuke.HttpModules"/>
                <add name="RequestFilter" type="DotNetNuke.HttpModules.RequestFilter.RequestFilterModule, DotNetNuke.HttpModules"/>
                <add name="UrlRewrite" type="DotNetNuke.HttpModules.UrlRewriteModule, DotNetNuke.HttpModules"/>
                <add name="Exception" type="DotNetNuke.HttpModules.Exceptions.ExceptionModule, DotNetNuke.HttpModules"/>
                <add name="UsersOnline" type="DotNetNuke.HttpModules.UsersOnline.UsersOnlineModule, DotNetNuke.HttpModules"/>
                <add name="DNNMembership" type="DotNetNuke.HttpModules.Membership.MembershipModule, DotNetNuke.HttpModules"/>
                <add name="Personalization" type="DotNetNuke.HttpModules.Personalization.PersonalizationModule, DotNetNuke.HttpModules"/>
                <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
                <add name="Analytics" type="DotNetNuke.HttpModules.Analytics.AnalyticsModule, DotNetNuke.HttpModules"/>
                <add name="RadUploadModule" type="Telerik.Web.UI.RadUploadHttpModule, Telerik.Web.UI"/>
            </httpModules>
            <httpHandlers>
                <!-- This is for CAPTCHA support -->
                <add verb="*" path="*.captcha.aspx" type="DotNetNuke.UI.WebControls.CaptchaHandler, DotNetNuke"/>
                <!-- This is for Serving files, secure, insecure, from database -->
                <add verb="*" path="LinkClick.aspx" type="DotNetNuke.Services.FileSystem.FileServerHandler, DotNetNuke"/>
                <!-- This adds syndication support -->
                <add verb="*" path="RSS.aspx" type="DotNetNuke.Services.Syndication.RssHandler, DotNetNuke"/>
                <!-- This adds legacy support for the Logoff page -->
                <add verb="*" path="Logoff.aspx" type="DotNetNuke.Services.Authentication.LogOffHandler, DotNetNuke"/>
                <!-- ASP.NET AJAX support -->
                <remove verb="*" path="*.asmx"/>
                <add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
                <add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
                <add verb="GET,HEAD" path="ScriptResource.axd" validate="false" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
                <add verb="*" path="User.aspx" type="DotNetNuke.Services.UserProfile.UserProfilePageHandler, DotNetNuke"/>
                <add verb="*" path="Telerik.RadUploadProgressHandler.ashx" type="Telerik.Web.UI.Upload.RadUploadProgressHandler"/>
                <add verb="*" path="Telerik.Web.UI.WebResource.axd" validate="false" type="Telerik.Web.UI.WebResource"/>
          <add verb="*" path="ChartImage.axd" type="Telerik.Web.UI.ChartHttpHandler, Telerik.Web.UI, Culture=neutral"/>
                <add verb="*" path="Sitemap.aspx" type="DotNetNuke.Services.Sitemap.SitemapHandler, DotNetNuke"/>
                <add verb="*" path="*.htmtemplate" type="DotNetNuke.HtmlEditor.TelerikEditorProvider.HtmTemplateFileHandler, DotNetNuke.HtmlEditor.TelerikEditorProvider"/>
          <add path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler" verb="*" validate="false" />
          <add path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler" verb="*" validate="false" />
        </httpHandlers>
            <!-- set code access security trust level - this is generally set in the machine.config
        <trust level="Medium" originUrl=".*" />
        -->
            <!-- set debugmode to false for running application -->
            <compilation debug="true" strict="false">
                <buildProviders>
                    <remove extension=".resx"/>
                    <remove extension=".resources"/>
                </buildProviders>
                <assemblies>
                    <add assembly="Microsoft.VisualBasic, Version=8.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
                    <add assembly="System.DirectoryServices, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
                    <add assembly="System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
                    <add assembly="System.Management, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
                    <add assembly="System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
                    <add assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
                    <add assembly="System.Xml.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
                    <add assembly="System.Data.DataSetExtensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
                    <add assembly="System.Data.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
                    <add assembly="System.Web.Abstractions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
                    <add assembly="System.Windows.Forms, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
                    <add assembly="System.Speech, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/></assemblies>
                <!-- register your app_code subfolders to generate granular assemblies during compilation
          <codeSubDirectories>
            <add directoryName="sub-directory name"/>
          </codeSubDirectories>
          -->
            </compilation>
            <!-- permits errors to be displayed for remote clients -->
            <customErrors mode="RemoteOnly"/>
            <!-- Forms or Windows authentication -->
            <authentication mode="Forms">
                <forms name=".DOTNETNUKE" protection="All" timeout="60" cookieless="UseCookies"/>
            </authentication>
            <!--
        <identity impersonate="true"/>
        <authentication mode="Windows">
        </authentication>
        -->
            <!-- allow large file uploads -->
            <httpRuntime useFullyQualifiedRedirectUrl="true" maxRequestLength="8192" requestLengthDiskThreshold="8192"/>
            <httpCookies httpOnlyCookies="true" requireSSL="false" domain=""/>
            <!--  GLOBALIZATION
        This section sets the globalization settings of the application.
        Utf-8 is not supported on Netscape 4.x
        If you need netscape compatiblity leave iso-8859-1.
        UTF-8 is recommended for complex languages
        -->
            <globalization culture="en-US" uiCulture="en" requestEncoding="UTF-8" responseEncoding="UTF-8" fileEncoding="UTF-8"/>
            <!--<globalization culture="en-US" uiCulture="en"  fileEncoding="iso-8859-1" requestEncoding="iso-8859-1" responseEncoding="iso-8859-1"/>-->
            <!-- page level options -->
            <pages validateRequest="false" enableViewStateMac="true" enableEventValidation="false" viewStateEncryptionMode="Always">
                <namespaces>
                    <add namespace="System.ComponentModel"/>
                    <add namespace="System.Data"/>
                    <add namespace="System.Data.SqlClient"/>
                    <add namespace="System.Drawing"/>
                    <add namespace="Microsoft.VisualBasic"/>
                    <add namespace="System.Globalization"/>
                    <add namespace="DotNetNuke.Services.Localization"/>
                    <add namespace="DotNetNuke.Entities.Users"/>
                    <add namespace="DotNetNuke"/>
                    <add namespace="DotNetNuke.Common"/>
                    <add namespace="DotNetNuke.Data"/>
                    <add namespace="DotNetNuke.Framework"/>
                    <add namespace="DotNetNuke.Modules"/>
                    <add namespace="DotNetNuke.Security"/>
                    <add namespace="DotNetNuke.Services"/>
                    <add namespace="DotNetNuke.UI"/>
                    <add namespace="DotNetNuke.Entities.Portals"/>
                    <add namespace="DotNetNuke.Common.Utilities"/>
                    <add namespace="DotNetNuke.Services.Exceptions"/>
                    <add namespace="DotNetNuke.Entities.Tabs"/>
                </namespaces>
                <controls>
                    <add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
                    <add tagPrefix="asp" namespace="System.Web.UI.WebControls" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
                </controls>
            </pages>
            <!-- ASP.NET 2 Membership/Profile/Role and AnonymousAuthentication Providers -->
            <!-- anonymousIdentification configuration:
              enabled="[true|false]"                              Feature is enabled?
              cookieName=".ASPXANONYMOUS"                         Cookie Name
              cookieTimeout="100000"                              Cookie Timeout in minutes
              cookiePath="/"                                      Cookie Path
              cookieRequireSSL="[true|false]"                     Set Secure bit in Cookie
              cookieSlidingExpiration="[true|false]"              Reissue expiring cookies?
              cookieProtection="[None|Validation|Encryption|All]" How to protect cookies from being read/tampered
              domain="[domain]"                                   Enables output of the "domain" cookie attribute set to the specified value
            -->
            <anonymousIdentification enabled="true" cookieName=".ASPXANONYMOUS" cookieTimeout="100000" cookiePath="/" cookieRequireSSL="false" cookieSlidingExpiration="true" cookieProtection="None" domain=""/>
            <membership defaultProvider="AspNetSqlMembershipProvider" userIsOnlineTimeWindow="15">
                <providers>
                    <clear/>
                    <!-- Configuration for AspNetSqlMembershipProvider:
                    connectionStringName="string"               Name corresponding to the entry in <connectionStrings> section where the connection string for the provider is specified
                    maxInvalidPasswordAttempts="int"            The number of failed password attempts, or failed password answer attempts that are allowed before locking out a user?s account
                    passwordAttemptWindow="int"                 The time window, in minutes, during which failed password attempts and failed password answer attempts are tracked
                    enablePasswordRetrieval="[true|false]"      Should the provider support password retrievals
                    enablePasswordReset="[true|false]"          Should the provider support password resets
                    requiresQuestionAndAnswer="[true|false]"    Should the provider require Q & A
                    minRequiredPasswordLength="int"             The minimum password length
                    minRequiredNonalphanumericCharacters="int"  The minimum number of non-alphanumeric characters
                    applicationName="string"                    Optional string to identity the application: defaults to Application Metabase path
                    requiresUniqueEmail="[true|false]"          Should the provider require a unique email to be specified
                    passwordFormat="[Clear|Hashed|Encrypted]"   Storage format for the password: Hashed (SHA1), Clear or Encrypted (Triple-DES)
                    description="string"                        Description of what the provider does
                    -->
                    <add name="AspNetSqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider" connectionStringName="SiteSqlServer" enablePasswordRetrieval="true" enablePasswordReset="true" requiresQuestionAndAnswer="false" minRequiredPasswordLength="7" minRequiredNonalphanumericCharacters="0" requiresUniqueEmail="false" passwordFormat="Encrypted" applicationName="DotNetNuke" description="Stores and retrieves membership data from the local Microsoft SQL Server database"/>
                </providers>
            </membership>
        </system.web>
        <runtime>
            <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
                <probing privatePath="bin;bin\HttpModules;bin\Providers;bin\Modules;bin\Support;"/>
                <dependentAssembly>
                    <assemblyIdentity name="Telerik.Web.UI" publicKeyToken="121fae78165ba3d4"/>
                    <!--Upgraded by DotNetNuke.Telerik.Web version 5.6.2 - Date: 4/1/2011 12:08:22 PM-->
                    <!--<bindingRedirect oldVersion="2008.0.0.0-2020.0.0.0" newVersion="2010.03.1317.35" xmlns="urn:schemas-microsoft-com:asm.v1" />-->
                    <bindingRedirect oldVersion="2008.0.0.0-2020.0.0.0" newVersion="2011.1.315.35" />
                </dependentAssembly>
            </assemblyBinding>
            <assemblyBinding appliesTo="v2.0.50727" xmlns="urn:schemas-microsoft-com:asm.v1"><dependentAssembly>
                    <assemblyIdentity name="System.Web.Extensions" publicKeyToken="31bf3856ad364e35"/>
                    <bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="3.5.0.0"/>
                </dependentAssembly>
                <dependentAssembly>
                    <assemblyIdentity name="System.Web.Extensions.Design" publicKeyToken="31bf3856ad364e35"/>
                    <bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="3.5.0.0"/>
                </dependentAssembly>
            </assemblyBinding></runtime>
        <dotnetnuke>
            <htmlEditor defaultProvider="TelerikEditorProvider">
                <providers>
                    <clear/>
                    <!--Upgraded by DotNetNuke.TelerikEditorProvider version 5.6.2 - Date: 4/1/2011 12:08:40 PM-->
                    <!--<add name="TelerikEditorProvider" type="DotNetNuke.HtmlEditor.TelerikEditorProvider.EditorProvider, DotNetNuke.HtmlEditor.TelerikEditorProvider" providerPath="~/Providers/HtmlEditorProviders/Telerik/" toolsFile="~/Providers/HtmlEditorProviders/Telerik/Config/ToolsDefault.xml" configFile="~/Providers/HtmlEditorProviders/Telerik/Config/ConfigDefault.xml" FilterHostExtensions="True" />-->
                    <add name="TelerikEditorProvider" type="DotNetNuke.HtmlEditor.TelerikEditorProvider.EditorProvider, DotNetNuke.HtmlEditor.TelerikEditorProvider" providerPath="~/Providers/HtmlEditorProviders/Telerik/" toolsFile="~/Providers/HtmlEditorProviders/Telerik/Config/ToolsDefault.xml" configFile="~/Providers/HtmlEditorProviders/Telerik/Config/ConfigDefault.xml" FilterHostExtensions="True"/>
                </providers>
            </htmlEditor>
            <navigationControl defaultProvider="DNNMenuNavigationProvider">
                <providers>
                    <clear/>
                    <add name="DNNDropDownNavigationProvider" type="DotNetNuke.NavigationControl.DNNDropDownNavigationProvider, DotNetNuke.DNNDropDownNavigationProvider" providerPath="~\Providers\NavigationProviders\DNNDropDownNavigationProvider\"/>
                    <add name="ASP2MenuNavigationProvider" type="DotNetNuke.NavigationControl.ASP2MenuNavigationProvider, DotNetNuke.ASP2MenuNavigationProvider" providerPath="~\Providers\NavigationProviders\ASP2MenuNavigationProvider\"/>
                    <add name="DNNMenuNavigationProvider" type="DotNetNuke.NavigationControl.DNNMenuNavigationProvider, DotNetNuke.DNNMenuNavigationProvider" providerPath="~\Providers\NavigationProviders\DNNMenuNavigationProvider\"/>
                    <add name="DNNTreeNavigationProvider" type="DotNetNuke.NavigationControl.DNNTreeNavigationProvider, DotNetNuke.DNNTreeNavigationProvider" providerPath="~\Providers\NavigationProviders\DNNTreeNavigationProvider\"/>
                    <add name="SolpartMenuNavigationProvider" type="DotNetNuke.NavigationControl.SolpartMenuNavigationProvider, DotNetNuke.SolpartMenuNavigationProvider" providerPath="~\Providers\NavigationProviders\SolpartMenuNavigationProvider\"/>
                </providers>
            </navigationControl>
            <searchIndex defaultProvider="ModuleIndexProvider">
                <providers>
                    <clear/>
                    <add name="ModuleIndexProvider" type="DotNetNuke.Services.Search.ModuleIndexer, DotNetNuke.Search.Index" providerPath="~\Providers\SearchProviders\ModuleIndexer\"/>
                </providers>
            </searchIndex>
            <searchDataStore defaultProvider="SearchDataStoreProvider">
                <providers>
                    <clear/>
                    <add name="SearchDataStoreProvider" type="DotNetNuke.Services.Search.SearchDataStore, DotNetNuke.Search.DataStore" providerPath="~\Providers\SearchProviders\SearchDataStore\"/>
                </providers>
            </searchDataStore>
            <data defaultProvider="SqlDataProvider">
                <providers>
                    <clear/>
                    <add name="SqlDataProvider" type="DotNetNuke.Data.SqlDataProvider, DotNetNuke.SqlDataProvider" connectionStringName="SiteSqlServer" upgradeConnectionString="" providerPath="~\Providers\DataProviders\SqlDataProvider\" objectQualifier="" databaseOwner="dbo"/>
                </providers>
            </data>
            <logging defaultProvider="DBLoggingProvider">
                <providers>
                    <clear/>
                    <add name="DBLoggingProvider" type="DotNetNuke.Services.Log.EventLog.DBLoggingProvider.DBLoggingProvider, DotNetNuke.Provider.DBLoggingProvider" providerPath="~\Providers\LoggingProviders\DBLoggingProvider\"/>
                </providers>
            </logging>
            <scheduling defaultProvider="DNNScheduler">
                <providers>
                    <clear/>
                    <add name="DNNScheduler" type="DotNetNuke.Services.Scheduling.DNNScheduling.DNNScheduler, DotNetNuke.DNNScheduler" providerPath="~\Providers\SchedulingProviders\DNNScheduler\" debug="false" maxThreads="1"/>
                </providers>
            </scheduling>
            <friendlyUrl defaultProvider="DNNFriendlyUrl">
                <providers>
                    <clear/>
                    <add name="DNNFriendlyUrl" type="DotNetNuke.Services.Url.FriendlyUrl.DNNFriendlyUrlProvider, DotNetNuke.HttpModules" includePageName="true" regexMatch="[^a-zA-Z0-9 _-]" urlFormat="humanfriendly"/>
                </providers>
            </friendlyUrl>
            <caching defaultProvider="FileBasedCachingProvider">
                <providers>
                    <clear/>
                    <add name="FileBasedCachingProvider" type="DotNetNuke.Services.Cache.FileBasedCachingProvider.FBCachingProvider, DotNetNuke.Caching.FileBasedCachingProvider" providerPath="~\Providers\CachingProviders\FileBasedCachingProvider\"/>
                </providers>
            </caching>
            <authentication defaultProvider="ADSIAuthenticationProvider">
                <providers>
                    <clear/>
                    <add name="ADSIAuthenticationProvider" type="DotNetNuke.Authentication.ActiveDirectory.ADSI.ADSIProvider, DotNetNuke.Authentication.ActiveDirectory" providerPath="~\Providers\AuthenticationProviders\ADSIProvider\"/>
                </providers>
            </authentication>
            <members defaultProvider="AspNetMembershipProvider">
                <providers>
                    <clear/>
                    <add name="AspNetMembershipProvider" type="DotNetNuke.Security.Membership.AspNetMembershipProvider, DotNetNuke.Provider.AspNetProvider" providerPath="~\Providers\MembershipProviders\AspNetMembershipProvider\"/>
                </providers>
            </members>
            <roles defaultProvider="DNNRoleProvider">
                <providers>
                    <clear/>
                    <add name="DNNRoleProvider" type="DotNetNuke.Security.Membership.DNNRoleProvider, DotNetNuke.Provider.DNNProvider" providerPath="~\Providers\MembershipProviders\DNNMembershipProvider\"/>
                </providers>
            </roles>
            <profiles defaultProvider="DNNProfileProvider">
                <providers>
                    <clear/>
                    <add name="DNNProfileProvider" type="DotNetNuke.Security.Profile.DNNProfileProvider, DotNetNuke.Provider.DNNProvider" providerPath="~\Providers\MembershipProviders\DNNProfileProvider\"/>
                </providers>
            </profiles>
            <permissions defaultProvider="CorePermissionProvider">
                <providers>
                    <clear/>
                    <add name="CorePermissionProvider" type="DotNetNuke.Security.Permissions.CorePermissionProvider, DotNetNuke.Provider.CorePermissionProvider" providerPath="~\Providers\PermissionProviders\CorePermissionProvider\"/>
                </providers>
            </permissions>
            <moduleCaching defaultProvider="FileModuleCachingProvider">
                <providers>
                    <clear/>
                    <add name="FileModuleCachingProvider" type="DotNetNuke.Services.ModuleCache.FileProvider, DotNetNuke.Provider.ModuleCaching.FileProvider" providerPath="~\Providers\ModuleCachingProviders\FileModuleCachingProvider\"/>
                    <add name="MemoryModuleCachingProvider" type="DotNetNuke.Services.ModuleCache.MemoryProvider, DotNetNuke.Provider.ModuleCaching.MemoryProvider" providerPath="~\Providers\ModuleCachingProviders\MemoryModuleCachingProvider\"/>
                </providers>
            </moduleCaching>
            <outputCaching defaultProvider="FileOutputCachingProvider">
                <providers>
                    <clear/>
                </providers>
            </outputCaching>
            <sitemap defaultProvider="coreSitemapProvider">
                <providers>
                    <clear/>
                    <add name="coreSitemapProvider" type="DotNetNuke.SitemapProviders.CoreSitemapProvider, DotNetNuke.SitemapProviders.CoreSitemapProvider" providerPath="~\Providers\MembershipProviders\Sitemap\CoreSitemapProvider\"/>
                </providers>
            </sitemap>
        </dotnetnuke>
    </configuration>


    I searched a lot for the solution on the forum and via google but without of luck.
    If anybody had similar or the same problem, please let me know what is the solution or give me link to the post where that info can be found.

    THANK YOU VERY MUCH!!!
    Marko
  2. Rumen
    Admin
    Rumen avatar
    13755 posts

    Posted 13 Apr 2011 Link to this post

    Hi Marko,

    I examined the web.config file and noticed that you use the RadEditor's DNN Provider which is implemented and supported by DotNetNuke, e.g.

    <htmlEditor defaultProvider="TelerikEditorProvider">
                <providers>
                    <clear/>
                    <!--Upgraded by DotNetNuke.TelerikEditorProvider version 5.6.2 - Date: 4/1/2011 12:08:40 PM-->
                    <!--<add name="TelerikEditorProvider" type="DotNetNuke.HtmlEditor.TelerikEditorProvider.EditorProvider, DotNetNuke.HtmlEditor.TelerikEditorProvider" providerPath="~/Providers/HtmlEditorProviders/Telerik/" toolsFile="~/Providers/HtmlEditorProviders/Telerik/Config/ToolsDefault.xml" configFile="~/Providers/HtmlEditorProviders/Telerik/Config/ConfigDefault.xml" FilterHostExtensions="True" />-->
                    <add name="TelerikEditorProvider" type="DotNetNuke.HtmlEditor.TelerikEditorProvider.EditorProvider, DotNetNuke.HtmlEditor.TelerikEditorProvider" providerPath="~/Providers/HtmlEditorProviders/Telerik/" toolsFile="~/Providers/HtmlEditorProviders/Telerik/Config/ToolsDefault.xml" configFile="~/Providers/HtmlEditorProviders/Telerik/Config/ConfigDefault.xml" FilterHostExtensions="True"/>
                </providers>
            </htmlEditor>

    The Professional DNN provider of RadEditor (DotNetNuke.HtmlEditor.TelerikEditorProvider.EditorProvider) that comes with the DNN 5.x.x installation, is implementated by DotNetNuke developers and it is not supported by Telerik. Our suggestion is to post the question about how to configure RadEditor in the DNN forums. For example in this one: Taming (customizing) The new Telerik RadEditor.

    Best regards,
    Rumen
    the Telerik team

    Browse the vast support resources we have to jump start your development with RadControls for ASP.NET AJAX. See how to integrate our AJAX controls seamlessly in SharePoint 2007/2010 visiting our common SharePoint portal.

  3. Henry Kwan
    Henry  Kwan avatar
    1 posts
    Member since:
    Oct 2009

    Posted 05 Jul 2011 Link to this post

    The Dotnetnuke 5.06.02 have a crash when you using RadEditor and DNN RadEditor in the same project.
    If you have the same problem related to the issue of Telerik.Web.UI.DialogHandler not registered in the web.config.

    please do the following:
    1. Check your web.config file have this line or not in <system.webServer><handlers>, if not in there add that line in and please remember to change the Path to Telerik.Web.UI.DialogHandler.axd
     
    <add name="Telerik_Web_UI_DialogHandler_aspx" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler" />
    or if you have this line please change the value of the path to Telerik.Web.UI.DialogHandler.axd

    2. In RadEditor please do this, see I added in the last line DialogHandlerUrl="~/Telerik.Web.UI.DialogHandler.axd"
    <telerik:RadEditor ID="RadNews" runat="server" Skin="Windows7" Width="870" ImageManager-UploadPaths="/portals/0/"
                                            ImageManager-DeletePaths="/portals/0/" ImageManager-ViewPaths="/portals/0/" ImageManager-MaxUploadFileSize="4096000"
                                            DocumentManager-ViewPaths="/portals/0/" DocumentManager-DeletePaths="/portals/0/"
                                            DocumentManager-UploadPaths="/portals/0/" DocumentManager-MaxUploadFileSize="4096000"
                                            MediaManager-UploadPaths="" MediaManager-DeletePaths="" MediaManager-ViewPaths=""
                                            MediaManager-MaxUploadFileSize="4096000" FlashManager-ViewPaths="/portals/0/"
                                            FlashManager-UploadPaths="/portals/0/" FlashManager-DeletePaths="/portals/0/"
                                            FlashManager-MaxUploadFileSize="4096000" SilverlightManager-ViewPaths="/portals/0/"
                                            SilverlightManager-UploadPaths="/portals/0/" SilverlightManager-MaxUploadFileSize="4096000"
                                            SilverlightManager-DeletePaths="/portals/0/" TemplateManager-ViewPaths="/portals/0/Templates/ClientTemplates/"
                                            TemplateManager-UploadPaths="/portals/0/Templates/ClientTemplates/" TemplateManager-DeletePaths="/portals/0/Templates/ClientTemplates/"
                                            TemplateManager-MaxUploadFileSize="4096000" ToolsFile="/DesktopModules/Membership/ClientProfileEdit/ToolsFileLimitedToClientEdit.xml"
                                            DialogHandlerUrl="~/Telerik.Web.UI.DialogHandler.axd">
                                            <CssFiles>
                                                <telerik:EditorCssFile Value="/portals/0/Skins/Star3/editor.css" />
                                            </CssFiles>
                                        </telerik:RadEditor>

    if you not add this line, the RadEditor cannot bring out the dialog. if you not change the value toTelerik.Web.UI.DialogHandler.axd in web.config file, the dnn editor will also not bring up the dialog correctly either said object reference not found or something else.

    you must do both together in web.config and your project to solve this problem.
Back to Top