This is a migrated thread and some comments may be shown as answers.

Batch edit delete & add new record bug

1 Answer 64 Views
Grid
This is a migrated thread and some comments may be shown as answers.
Hon Wai
Top achievements
Rank 1
Hon Wai asked on 19 Sep 2014, 01:37 AM
Hi, I have found some weird bugs when playing with RadGrid in batch edit mode, here's the scenario:

1. First, I will add new record, then you can see the red triangle indicating changes
2. Then, I delete this record, and then I add new record again
3. Things getting strange from now on, when you are editing fields, e.g. when you lost focus, an item in combobox is automatically selected instead of validation prompted, also after one field edit done, I am not able to see the red triangle in each cell, this happen to "the" row only.

Also, I have try the demo http://demos.telerik.com/aspnet-ajax/grid/examples/data-editing/batch-editing/defaultcs.aspx
Same behavior is occured. 

Please help me solve the bug.

Thanks,
Hon Wai

1 Answer, 1 is accepted

Sort by
0
Konstantin Dikov
Telerik team
answered on 23 Sep 2014, 10:38 AM
Hello Hon,

Thank you for reporting this to us.

After some testing I may confirm that both of the described behaviors are bugs with the current implementation of Batch Editing and one of them is related to the column's validator.

I am looking this in our system, so our developers team could further investigate this and provide a fix in one of our future releases.

For bringing the issue to our attention you could find your Telerik Points updated.

Please excuse us for any inconvenience caused by this.


Regards,
Konstantin Dikov
Telerik
 

Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

 
Tags
Grid
Asked by
Hon Wai
Top achievements
Rank 1
Answers by
Konstantin Dikov
Telerik team
Share this question
or