Rad Editor Dialog problem

2 posts, 0 answers
  1. Mayank
    Mayank avatar
    1 posts
    Member since:
    Jan 2012

    Posted 27 Jan 2012 Link to this post

    Hi,
        When I open the dialog Image Manager/HyperLink Manager/ Flash Manager, it gives error "Resource can not found (/Telerik.Web.UI.DialogHandler.aspx)" but when I add the handler in web.config file it works fine.
    <system.webServer>
      <handlers>
    <add name="Telerik_Web_UI_DialogHandler_aspx" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler" />
          <add name="Telerik_Web_UI_WebResource_axd" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" />
    </handlers>
    </system.webServer>
    and  <httpHandlers>
    <add path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler" verb="*" validate="false"/>
        </httpHandlers>
    but I don't like to add this setting in web.config file so Is another any option available for RadEditor Dialog works properly? Please find the attached screenshot , because when i add this setting in web.config file , there is problem when deploying in shared hosting server.
  2. Rumen
    Admin
    Rumen avatar
    14366 posts

    Posted 30 Jan 2012 Link to this post

    Hello,

    Yes, the registration of the dialog handlers in the web.config is mandatory for the RadEditor's dialog to work.

    What you can try is to create a physical empty Telerik.Web.UI.DialogHandler.aspx file in the root of the web site and set the DialogHandlerUrl property to point to it.

    <telerik:radeditor runat="server" DialogHandlerUrl="~/Telerik.Web.UI.DialogHandler.aspx" ...

    If this does not work you should register the handlers in the web.config file.

    All the best,
    Rumen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now
Back to Top