401.2 on RadChart

Thread is closed for posting
3 posts, 0 answers
  1. Cloud
    Cloud avatar
    24 posts
    Member since:
    Oct 2008

    Posted 27 Aug 2009 Link to this post

    I have a page which contains some search parameters and a telerik chart.
    At the beginning, the page can be rendered because the chart is invisible, once i click the generate chart button, it run for a long time and finally prompt for username and password, after entering 3 times, it shows me the 401.2 error.

    The web application is using 2008 Q3 on IIS 6.

    Here is part of my web.config

    <location path="Telerik.Web.UI.WebResource.axd">  
            <system.web> 
                <authorization> 
                    <allow users="*"/>  
                </authorization> 
            </system.web> 
        </location> 
        <location path="ChartImage.axd">  
            <system.web> 
                <authorization> 
                    <allow users="*"/>  
                </authorization> 
            </system.web> 
        </location> 
     
             .......  
     
    <httpHandlers> 
                <remove path="*.asmx" verb="*"/>  
                <add path="*.asmx" verb="*" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" validate="false"/>  
                <add path="*_AppService.axd" verb="*" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" validate="false"/>  
                <add path="ScriptResource.axd" verb="GET,HEAD" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" validate="false"/>  
                <add path="Telerik.RadUploadProgressHandler.ashx" verb="*" type="Telerik.Web.UI.Upload.RadUploadProgressHandler, Telerik.Web.UI"/>  
                <add path="Telerik.Web.UI.DialogHandler.aspx" verb="*" type="Telerik.Web.UI.DialogHandler, Telerik.Web.UI, Culture=neutral, PublicKeyToken=121fae78165ba3d4"/>  
                <add path="Telerik.Web.UI.SpellCheckHandler.axd" verb="*" type="Telerik.Web.UI.SpellCheckHandler, Telerik.Web.UI, Culture=neutral, PublicKeyToken=121fae78165ba3d4"/>  
                <add path="ChartImage.axd" verb="*" type="Telerik.Web.UI.ChartHttpHandler, Telerik.Web.UI, Culture=neutral, PublicKeyToken=121fae78165ba3d4" validate="false"/>  
                <add path="Telerik.Web.UI.WebResource.axd" verb="*" type="Telerik.Web.UI.WebResource, Telerik.Web.UI" validate="false"/>  
            </httpHandlers> 
  2. Cloud
    Cloud avatar
    24 posts
    Member since:
    Oct 2008

    Posted 27 Aug 2009 Link to this post

    Additional information, this application is only enabled for window integrated security, annoymous login is not allowed.

    I have also tried to set allowusers="?", this doesn't work as well.
  3. Vladimir Milev
    Admin
    Vladimir Milev avatar
    1061 posts

    Posted 02 Sep 2009 Link to this post

    Hello Cloud,

    Are you by any chance using "UseSession=false" in that particular chart?

    Kind regards,
    Vladimir Milev
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
Back to Top