This is a migrated thread and some comments may be shown as answers.

XML Parsing Error: no element found

1 Answer 136 Views
Editor
This is a migrated thread and some comments may be shown as answers.
Ben de Groot
Top achievements
Rank 1
Ben de Groot asked on 05 Aug 2010, 06:50 AM
I am not an asp.net expert, I have the following issue with the Telrik editor when you click on any of the Dialogue Boxes. I am sure it will be some web.config issue. Has anyone got any idea on a fix or where I am going wrong?

XML Parsing Error: no element found.

Check it out at https://www.diveengine.com/editor/Default2.aspx

1 Answer, 1 is accepted

Sort by
0
Rumen
Telerik team
answered on 05 Aug 2010, 08:47 AM
Hi Ben,

The dialogs configuration in your Web.Config File is set correctly .The problem is due to some Firewall, Antivirus or WebSense tool that is blocking the RadEditor's dialogs URLs which size exceed the specified one.

The RadEditor dialogs receive encoded arguments such as skin and configuration information (for example the ImagesPaths, DialogCssFiles) via the URL. In addition RadEditor follows the HTTP rules, which allow up to 2000 symbols to be used for the URL length. However, if some monitoring program such as WebSense or a Proxy server decrease the URL length for example to 1700 symbols then this will break the loading of the editor dialogs and cause errors like "The page cannot be found" or "Invalid Request" error or load blank dialogs.

To fix the problem contact your network administrator and ask him / her to increase the allowed URL length to the allowed by the HTTP rules 2000 symbols.

Kind regards,
Rumen
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Tags
Editor
Asked by
Ben de Groot
Top achievements
Rank 1
Answers by
Rumen
Telerik team
Share this question
or