This is a migrated thread and some comments may be shown as answers.

Wrong Font Getting Rendered

1 Answer 174 Views
Report Designer (standalone)
This is a migrated thread and some comments may be shown as answers.
Ian
Top achievements
Rank 1
Ian asked on 08 Dec 2016, 05:00 PM

Hello

We have .trdx reports that have text boxes set to Roboto font.  In preview and when I run our application locally, it renders correctly the roboto font.  When I run a report in our QA (and other) environments, most of the text boxes randomly are rendered as MS Sans Serif font.

I tried several things to get all text boxes Roboto,including setting the font in containing elements and copying the style from elements that are correct and pasting them into ones that are incorrect (in the Report Designer).  I have also tried deleting the texts boxes that get rendered incorrect and copying ones that are correct and changing the text.  This has the effect of shifting which text box is correct and which isn't.  Like musical chairs.

Exploring the page source of the rendered html, it appears guid classes (names starting with "s") get set for each text box, some of them have roboto font, some MS Sans Serif.  It appears totally random.

Any ideas?

Thanks
Ian

 

1 Answer, 1 is accepted

Sort by
0
Stef
Telerik team
answered on 12 Dec 2016, 05:43 PM
Hi Ian,

Please verify all used fonts cover the requirements in Font is missing in report designers.
Then make fonts private in order to have the HTML preview correctly - add Telerik Reporting section and privateFonts section.

For the PDF generation, it is important to fully embed fonts in case the client machines lack the custom fonts - Font Requirements.

Regards,
Stef
Telerik by Progress
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Tags
Report Designer (standalone)
Asked by
Ian
Top achievements
Rank 1
Answers by
Stef
Telerik team
Share this question
or