This is a migrated thread and some comments may be shown as answers.

Wpf ReportViewer options do not display for export

3 Answers 64 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Jules
Top achievements
Rank 1
Jules asked on 11 Feb 2013, 08:35 PM
Is anyone else having this issue? I have a Wpf application that uses the Wpf ReportViewer, and when a report is loaded and you go to select a format for export, nothing appears on the screen (see the screenshot). However, if you click on the export drop-down's down arrow (and nothing appears) and press the up or down arrows followed by the enter key, the export begins and takes you to the file save screen. (If you know where the desired format is in the list and repeat this enough, eventually you get the format you desire.) If you click on the export drop-down's down arrow and never press the enter key, the application appears to be frozen.

The application is running in .Net 4.0 and uses Telerik Windows Controls 2012.3.1129.40 and Telerik Reporting 6.2.13.110. I had this problem a version or two ago and resolved it with an internal build, but now it's back. Help!

3 Answers, 1 is accepted

Sort by
0
Steve
Telerik team
answered on 14 Feb 2013, 03:59 PM
Hello Julia,

We suspect you're using custom template for the WPF report viewer from an older version of Telerik Reporting. In such scenarios, we recommend always getting the "fresh" template from the new Reporting version as we apply changes to the template regularly.

If you're still having problems, we would recommend opening a support ticket and attaching a sample runnable project that exhibits the problem, so we can investigate what is happening.

Regards,
Steve
the Telerik team

HAPPY WITH REPORTING? Do you feel that it is fantastic? Or easy to use? Or better than Crystal Reports? Tell the world, and help fellow developers! Write a short review about Telerik Reporting and Telerik Report Designer in Visual Studio Gallery today!

0
Jules
Top achievements
Rank 1
answered on 06 Mar 2013, 05:15 PM
Sorry, but "huh"?? I don't even know what a custom template for the report viewer is. Here's the XAML for the report viewer:

<telerikReport:ReportViewer x:Name="ReportViewer1" Grid.Row="1" ViewMode="PrintPreview" />

That's it. Very simple. And no, I don't set any attributes of the report viewer in the code, beyond changing which report to view. Any ideas?
0
Chavdar
Telerik team
answered on 11 Mar 2013, 04:12 PM
Hi,

Our suggestion is to upgrade to the latest version of Telerik Reporting (v7.0.13.228) which is available in your account and to the latest version of RadControls for WPF. If the problem still persists, please open a support ticket and send us a sample application which reproduces the issue.

All the best,
Chavdar
the Telerik team

Telerik Reporting Q1 2013 available for download with impressive new visualizations. Download today from your account.

Tags
General Discussions
Asked by
Jules
Top achievements
Rank 1
Answers by
Steve
Telerik team
Jules
Top achievements
Rank 1
Chavdar
Telerik team
Share this question
or