This is a migrated thread and some comments may be shown as answers.

Wizard windows disappears

7 Answers 47 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Axel
Top achievements
Rank 2
Axel asked on 07 Sep 2009, 04:06 PM
Hi

When creating a report using the Wizard, the Wizard window disappears when I am selecting fields for list items, groups etc.
This seems to happen when I try to expand the data explorer treeview and click the +/- boxes to expand specific fields.

Is this a known bug ?

reg.
Axel G.

7 Answers, 1 is accepted

Sort by
0
Steve
Telerik team
answered on 08 Sep 2009, 08:46 AM
Hello Axel,

Unfortunately we've not been able to reproduce the problem with the information you've provided. Please provide more info such as Visual Studio version, .NET version, Telerik Reporting version used, exact steps to follow to replicate this. You talk about report wizard, but you also mention Data Explorer window, however both cannot be opened at the same time. A video showing the described problem would be much appreciated.

Greetings,
Steve
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
0
Axel
Top achievements
Rank 2
answered on 10 Sep 2009, 10:38 AM
VS 2008 Version 9.0.30729.1 SP
MS .NET Version 3.5 SP1
Telerik Reporting Q2 2009 SP1 (3.1.9.807)

In VS i start by selecting Telerik - > Reporting -> Report Wizard
In the Telerik popup windows I press NEXT
- select a new report and click NEXT
- create a new datasource and click NEXT
- select Business Object Datasource and click NEXT
- I choose the object I wish to bind to and click NEXT
- select standard report type and click NEXT
- select fields for detail, grouping etc and at this stage, if I try to select the +/- box in the treeview (to dig deeper into field attributes), the window disappears.

reg.
Axel
0
Steve
Telerik team
answered on 10 Sep 2009, 03:27 PM
Hi Axel,

We've not been able to reproduce this on our end with some sample data on VS2008 with Q2 SP1 (see attached video), so we suspect that this might be related to the exact business object you're using. We would appreciate if you send it or if you're not allowed to, prepare a BO that causes the issue and send it instead. Once we review it, we would be able to provide you with more info.
Also as a test, you can try the same steps on a different machine and see if it would cause the crash there as well. This way we would exclude the possibility of this being a local issue (corrupted Reporting, Visual Studio etc.).

Greetings,
Steve
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
0
Axel
Top achievements
Rank 2
answered on 29 Sep 2009, 02:37 PM
Hi Steve,

I have not been able to pinpoint the problem. The video you sent be as proof of OK-ness does not cover where the problem lies.

I have found out that clicking / expanding nodes that contain table field attributes is OK, but clicking /expanding relationship fields i.e. nodes that point to a relationship table do not work. If I click on thoes the wizard closes.

You can propably re-create the problem by creating two tables ie. TableX with relationship to TableY. When you bring up TableX in the wizard try and click / expand the TableY node. The node will not expand and display it's elements, instead the wizard closes.

If you are still unable to recreate this error then I can send ypu my SQL dump with sample data, and pinpoint where the problem occurs. I would have incl. this attachment but do not know where to put it (it's to long for the codeblocks). 

reg.
Axel
0
Hrisi
Telerik team
answered on 01 Oct 2009, 03:10 PM
Hi Axel Gunnlaugsson,

You talk about tables, but you are trying to use them as business objects. Since we do not understand what exactly you are trying to achieve, we requested an example code, which will help us understand your needs. Your collaboration is greatly appreciated in order to unveil the problem.

 
Greetings,
Hrisi
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
0
Axel
Top achievements
Rank 2
answered on 02 Oct 2009, 12:54 AM
Sorry for being unclear.
I am working with objects (dbml), and what I am trying to do is open relationship to other objects (sorry I'm old school but I still see them as table(objects)). Is there a way to send you a video of this happening, because now I have one more problem with the report designet stalling. I.e. I must close and re-open to get it going again.

reg.
Axel
0
Steve
Telerik team
answered on 02 Oct 2009, 07:38 AM
Hello Axel,

We have no doubts that you're experiencing problems, but video would not help us much in reproducing it. Please open a support ticket and zip and attach a sample project which replicates the problem on your end. Once we review it, we would be able to provide you with more info on what is happening and fix it, if it is a problem on our end.

Looking forward to your reply.

Greetings,
Steve
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
Tags
General Discussions
Asked by
Axel
Top achievements
Rank 2
Answers by
Steve
Telerik team
Axel
Top achievements
Rank 2
Hrisi
Telerik team
Share this question
or