This is a migrated thread and some comments may be shown as answers.

why contents has different appearence between Edit mode and Display mode?

1 Answer 8 Views
WebParts for SharePoint
This is a migrated thread and some comments may be shown as answers.
hongming
Top achievements
Rank 1
hongming asked on 18 Aug 2010, 06:47 PM
I copied some content from a word doc into RadEditor control, why these content has different appearence between Edit mode and Display mode?
 
is it beacuse inheriting style from parents in Display mode? is there any properties that allow me to disconnect this inheritance?

1 Answer, 1 is accepted

Sort by
0
Stanimir
Telerik team
answered on 19 Aug 2010, 07:26 AM
Hi hongming,

I already answered to your question in the thread with ID 338600. How ever for your convenience I will paste the answer here as well.

First you need to review the following online help article: Defining custom CSS styles.

Now on your problem the reason for this behavior is that you do not have the same style sheets loaded in the RadEditor's content area and in the page in presentation mode. What I suggest you to do is by using developers tool such as IE developers toolbar for Internet Explorer or Firebug  for Firefox, check what styles are applied over the problem content  then make sure that you have the same cascading in the IFRAME of the editor.


Best wishes,
Stanimir
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Tags
WebParts for SharePoint
Asked by
hongming
Top achievements
Rank 1
Answers by
Stanimir
Telerik team
Share this question
or