This is a migrated thread and some comments may be shown as answers.

Virtual Directory

8 Answers 186 Views
Editor
This is a migrated thread and some comments may be shown as answers.
Neil
Top achievements
Rank 1
Neil asked on 31 Mar 2010, 02:17 PM
I have set the ImageManager view, upload and delete paths to a virtual directory and followed the info on this page and this page

The virtual directory is running under a specific domain account, with full control given to the folder and the share. IIS is serving the images, and I can navigate through the directory structure of the virtual directory in IIS.  I am also able to save, rename and delete files in the folder while connected as the domain account.

When I open the image manager dialog, the images in the folder are not being populated in the dialog, nor is the upload button enabled.

I tested with a folder on my hard-drive and was able to create, modify and delete images via the image manager.

Any help would be appreciated!






8 Answers, 1 is accepted

Sort by
0
Rumen
Telerik team
answered on 31 Mar 2010, 03:09 PM
Hi Neil,

If this virtual folder points to a physical folder located on another PC then see these articles:

Uploading images and files to a Shared Drive
and
Using RadFileExplorer with physical and shared folder's paths.

Kind regards,
Rumen
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
0
Neil
Top achievements
Rank 1
answered on 31 Mar 2010, 04:37 PM
Thanks for the reply Rumen.  I read, and followed the info on both knowledge base documents with out success.

I have attached a screenshot that shows how the virtual directory is set up.  The account that the virtual directory is running under has full control.

Thanks!
0
Neil
Top achievements
Rank 1
answered on 31 Mar 2010, 04:58 PM
File attached
0
Rumen
Telerik team
answered on 01 Apr 2010, 12:58 PM
Hi Neil,

Can you please set full permissions for the everyone user for the Images folder?

You can also see whether the files in the ~/files/_global/images/htmlLibrary folder are accessible in the web page with the following C# code:

protected void Page_Load(object sender, EventArgs e)
    {
        string resolvedPath = Server.MapPath("~/Images");
        Response.Write("The images folder resolves to: " + resolvedPath);
        foreach (string file in Directory.GetFiles(resolvedPath))
        {
            Response.Write("<br/>File: " + file);
        }
    }


For your convenience I have attached a video which demonstrates how to map a virtual folder that points to a shared drive and load its files in the Image manager of RadEditor Classic.

Kind regards,
Rumen
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
0
Neil
Top achievements
Rank 1
answered on 01 Apr 2010, 03:36 PM
Adding everyone did not work, but after some Googling we found a blog post by Rick Strahl which fixed the problem.  To determine the account that the application in running under we used <%= Environment.UserName %> - this returned ASPNET (IIS 5.1 - does not have appPools)

We then added a username and password to the machine.config so the app would run under an account that we specified and not the ASPNET account

C:\windows\Microsoft.NET\Framework\v2.0.50727\CONFIG

<processModel userName="domain\account" password="password" />

Hope this helps someone!
0
Rumen
Telerik team
answered on 02 Apr 2010, 11:17 AM
Hi Neil,

Thank you for sharing this solution with the community. We do appreciate your help and I updated your Telerik points.

All the best,
Rumen
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
0
Rinken
Top achievements
Rank 1
answered on 27 Jul 2010, 04:42 PM
Rumen,
I am struggling with similar issue where RadEditor.ImageManager version 6.6.3.0 is not able to recognize Sub Application Virtual Directory pointing to Remote Share. I had tried the function you provided that reads Directory and Files under VD and with impersonation enabled for the location that houses RadEditor,  I was successfully able to see the files.

Is there a solution to this problem other than changing processModel that is done at application level and not location based. This would be a big security issue (not that it works on my end either).

I confirmed the VD setup and that works perfect. Also verified the same by embedding image that is pointing to a file in Sub Application Virtual Directory.
0
Rumen
Telerik team
answered on 30 Jul 2010, 01:38 PM
Hi Rinken,

I am not sure whether this will solve the problem on our side, but impersonation could be enabled through the <identity> element in the web.config:
http://msdn.microsoft.com/en-us/library/xh507fc5%28VS.71%29.aspx

You can set it in your web application's web.config file, instead of globally in your machine.config file.

Best regards,
Rumen
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Tags
Editor
Asked by
Neil
Top achievements
Rank 1
Answers by
Rumen
Telerik team
Neil
Top achievements
Rank 1
Rinken
Top achievements
Rank 1
Share this question
or