Upload does not render

Thread is closed for posting
6 posts, 0 answers
  1. Zach
    Zach avatar
    13 posts
    Member since:
    Jan 2009

    Posted 19 Oct 2009 Link to this post

    I've tried everything I can think of but this control just will not render on my page.  From FireFox's error console, I can see the reason for this is because of 4 Javascript errors:

    Error: illegal character 
    Source File: http://localhost:2173/dev/Telerik.Web.UI.WebResource.axd?_TSM_HiddenField_=ScriptManager1_HiddenField&compress=1&_TSM_CombinedScripts_=%3b%3bSystem.Web.Extensions%2c+Version%3d3.5.0.0%2c+Culture%3dneutral%2c+PublicKeyToken%3d31bf3856ad364e35%3aen-US%3a0d787d5c-3903-4814-ad72-296cea810318%3aea597d4b%3ab25378d2%3bTelerik.Web.UI%2c+Version%3d2009.2.701.35%2c+Culture%3dneutral%2c+PublicKeyToken%3d121fae78165ba3d4%3aen-US%3a7e598a31-3beb-49a1-914c-5f530240f0ea%3a16e4e7cd%3af7645509%3a24ee1bba%3aa585d0d4 
    Line: 1 
    Source Code: 
    � `I�%&/m�{J�J��t��`$ؐ@�����iG#)�*��eVe]f@�흼 ��{���{��;�N'���?\fdl��J�ɞ!���?~|?"~�?�7�5��:��������t�g��������w~�w������?��-��O�=���������O��~������~��g�̿��������}��?�����/��=������������,���;��?���_�O�.��/��������������?���� 

    Error: ASP.NET Ajax client-side framework failed to load. 
    Source File: http://localhost:2173/dev/test2.aspx 
    Line: 40 
    Error: Sys is not defined 
    Source File: http://localhost:2173/dev/test2.aspx 
    Line: 46 
    Error: Sys is not defined 
    Source File: http://localhost:2173/dev/test2.aspx 
    Line: 64 

    Yes those weird characters are what shows up in the error console.  The entire contents of my page are as follows (I've registered my telerik reference in the web.config, works with all other telerik controls I've used so far):

    <%@ Page Language="C#" AutoEventWireup="true" CodeFile="Test2.aspx.cs" Inherits="Test2" %> 
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> 
    <html xmlns="http://www.w3.org/1999/xhtml"
    <head runat="server"
        <form runat="server"
        <telerik:RadScriptManager ID="ScriptManager1" runat="server" /> 
        <telerik:RadUpload runat="server" ID="RadUpload1" TargetFolder="~/uploads/flash"

    I've also registered the upload module and handler, disabled my URLRewriting, swapped the order of the modules/handlers...nothing worked.  A help article I read said to check Telerik.RadUploadProgressHandler.aspx (I assume this is for the old version and should be .ashx now) and make sure the line shows up:
    var rawProgressData = {InProgress:false,ProgressCounters:false};

    I'm in Full Trust and my web.config looks like this for the module/handler sections:

          <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=, Culture=neutral, PublicKeyToken=31BF3856AD364E35" /> 
          <add name="RadUploadModule" type="Telerik.Web.UI.RadUploadHttpModule" /> 
                <remove verb="*" path="*.asmx" /> 
                <add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=, Culture=neutral, PublicKeyToken=31BF3856AD364E35" /> 
                <add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=, Culture=neutral, PublicKeyToken=31BF3856AD364E35" /> 
                <add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=, Culture=neutral, PublicKeyToken=31BF3856AD364E35" validate="false" /> 
                <add path="Telerik.Web.UI.WebResource.axd" verb="*" type="Telerik.Web.UI.WebResource, Telerik.Web.UI" validate="false" /> 
                <add path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler" verb="*" validate="false" /> 
                <add path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler" verb="*" validate="false" /> 
                <add verb="*" path="Telerik.RadUploadProgressHandler.ashx" type="Telerik.Web.UI.RadUploadProgressHandler, Telerik.Web.UI" />     

    I would really like to use this control for some video uploads mainly for the progress area, so please help me.

  2. Genady Sergeev
    Genady Sergeev avatar
    1600 posts

    Posted 21 Oct 2009 Link to this post

    Hello Zach,

    Perhaps there is something wrong with the encodings  you are using. Can you please check this on some other browsers, like IE or Chrome. Does the issue persist?

    What happens when you open the RadUpload demos from your machine, is there any error like the one you experience? The demos can be found here.

    I have noticed that you use the Q2 version of our controls, can you please download the service pack from your account, is there any change in the situation?

    I have prepared very simple sample project that works fine on my side. Can you confirm that it is working/not working on your side?

    Genady Sergeev
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  3. Zach
    Zach avatar
    7 posts
    Member since:
    Jun 2004

    Posted 22 Oct 2009 Link to this post

    I tried upgrading the version of my controls, didn't help this problem.  I ran your demo and it worked fine after adding in my .dll files (except the progress window which I'll mention later).  The reason yours worked fine is because you are using ASP's script manager and not the Telerik one.  Sure enough, when I put the Telerik script manager on your demo, it broke in the same way.  Answering your earlier question, I can run Telerik's upload demo just fine, and it uses a Telerik script manager, so I don't know what that tells you.  Its the same issue in all three browsers (IE8, Chrome, FF).  So I'll just stick with the ASP script manager for now to fix this issue.

    Next issue: The progress window is buggy at best.  Even in your demo it doesn't show up all the time.  I've attributed part of this issue to be the fact that I'm working locally so the file is uploading extremely fast (probably faster than the progress window has time to react).  I throttled my connection to 2 MBPS and it seemed to work.  However, adding any additional module or handler (handler for RadEditor) to your demo makes the window not show up for the first few times through.  Something seems to work itself out eventually and then it magically starts coming up again.

    Is this common and will it always work after the first time it starts working again?  I don't want to publish a site with this feature if it will only work some of the time.
  4. Genady Sergeev
    Genady Sergeev avatar
    1600 posts

    Posted 28 Oct 2009 Link to this post

    Hi Geoff Wilson,

    The issues that you experience are quite strange and are by no means the standard behavior of the RadUpload/ProgressArea. I have tried adding RadScriptManager to my project, however, on my side everything worked fine. As for the RadEditor httpModule, on our demo site, there are multiple modules handling the request that are registered in the web.config. As you can easily verify this, the area is working without a problem there.

    Since we have troubles reproducing the fault that you experience, Is it possible to prepare and send us a sample project demonstrating the problems. This will allow to track and fix the issues as soon as possible.

    Best wishes,
    Genady Sergeev
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  5. Giovany
    Giovany avatar
    1 posts
    Member since:
    Apr 2011

    Posted 27 Apr 2011 Link to this post

    I'm working on a project that has the same errors,
    but I use RadScriptManager, do not know what to do. In normal chrome works
    and IE and Firefox displays the same error shown above. This application was migratedfrom Visual Studio 2008 we are using Visual Studio 2010 C #. It may be someincompatibility of version?
  6. Genady Sergeev
    Genady Sergeev avatar
    1600 posts

    Posted 03 May 2011 Link to this post

    Hello Geoff Wilson,

    Which version of IIS do you use and which version of the controls? Do you use forms/windows authentication? Could you please paste here the handlers/modules declarations of your web.config. This information is needed in order to troubleshoot the problem.

    Genady Sergeev
    the Telerik team

    Browse the vast support resources we have to jump start your development with RadControls for ASP.NET AJAX. See how to integrate our AJAX controls seamlessly in SharePoint 2007/2010 visiting our common SharePoint portal.

Back to Top