This is a migrated thread and some comments may be shown as answers.

Upgrading without recompiling...

8 Answers 323 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Baatezu
Top achievements
Rank 2
Baatezu asked on 20 Jun 2008, 01:07 PM
I'm probably missing something simple, I miss those the best. :)

How do I upgrade to the latest version of the telerik controls without having to rebuild every module (I'm making modules for DNN) that uses telerik controls?

I assume there is some setting in Visual Studio 2008 that I am missing.
I have the "Specific Version" set to false for the Telerik.Web.UI reference, which is the only telerik DLL I reference. I had the set for the 515 version and the previous as well, but everything is broken when I upload all the files to upgrade.

Any suggestions would be great. I can't seem to find anything else on it. I could be missing something super simple and overly obvious, so if there are a couple things that need to be done, I'll probably need it pretty explicit. hehe

8 Answers, 1 is accepted

Sort by
0
Daniel
Telerik team
answered on 23 Jun 2008, 12:43 PM
Hi Baatezu,

Actually our controls use strong names for their assemblies (DLL files). This means that your project will be built against a specific Telerik build. If you want to update the Telerik assemblies without recompiling your project, you need to update the web application's Web.config file and add the appropriate <bindingRedirect> element in order to redirect calls for the old assembly version to the new one.

Greetings,
Daniel
the Telerik team

Instantly find answers to your questions at the new Telerik Support Center
0
Baatezu
Top achievements
Rank 2
answered on 24 Jul 2008, 06:17 PM
With the Q2 release, I've tried the described method, but it doesn't seem to be working for me. :(
This is the relevant section of the web.config
<runtime> 
    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1"
      <probing privatePath="bin;bin\HttpModules;bin\Providers;bin\Modules;bin\Support;" /> 
      <dependentAssembly> 
            <assemblyIdentity name="Telerik.Web.UI"/> 
            <bindingRedirect oldVersion="0.0.0.0-65535.65535.65535.65535" newVersion="2008.2.723.20"/> 
         </dependentAssembly> 
    </assemblyBinding> 
  </runtime> 

Is there something I'm missing in this section, or anything else I need to do/add/ect?
0
Daniel
Telerik team
answered on 28 Jul 2008, 12:26 PM
Hi Baatezu,

Could you please try to set PublicKeyToken to assemblyIdentity and give us feedback on the result?

Regards,
Daniel
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
0
Baatezu
Top achievements
Rank 2
answered on 29 Jul 2008, 12:32 AM
  <runtime> 
    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1"
      <probing privatePath="bin;bin\HttpModules;bin\Providers;bin\Modules;bin\Support;" /> 
      <dependentAssembly> 
        <assemblyIdentity name="Telerik.Web.UI" Culture="neutral" PublicKeyToken="121fae78165ba3d" /> 
        <bindingRedirect oldVersion="0.0.0.0-65535.65535.65535.65535" newVersion="2008.2.723.20"/> 
      </dependentAssembly> 
    </assemblyBinding> 
  </runtime> 
This is what I have, and it still pops up the error that it can't find the 2008.1.619.20 version (which is what I compiled against)

Does what I have in my web.config look correct?
0
Daniel
Telerik team
answered on 29 Jul 2008, 01:33 PM
Hi Baatezu,

Please note that web.config file is case-sensitive (as every XML file). Thus try to change Culture to culture and PublicKeyToken to publicKeyToken.
 
Let me know whether these directions are helpful.

Regards,
Daniel
the Telerik team


Check out Telerik Trainer, the state of the art learning tool for Telerik products.
0
Baatezu
Top achievements
Rank 2
answered on 29 Jul 2008, 05:27 PM
  <runtime> 
    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1"
      <probing privatePath="bin;bin\HttpModules;bin\Providers;bin\Modules;bin\Support;" /> 
      <dependentAssembly> 
        <assemblyIdentity name="Telerik.Web.UI" culture="neutral" publicKeyToken="121fae78165ba3d" /> 
        <bindingRedirect oldVersion="0.0.0.0-65535.65535.65535.65535" newVersion="2008.2.723.20"/> 
      </dependentAssembly> 
    </assemblyBinding> 
  </runtime> 

and it still tells me
Could not load file or assembly 'Telerik.Web.UI, Version=2008.1.619.20, Culture=neutral, PublicKeyToken=121fae78165ba3d4' or one of its dependencies

I hate to bring it up so late in the game - but recently I found another setting I had to add elsewhere in my web.config to accommodate IIS 7, specifically, which I have, running on Vista Ultimate.

Is there some different trick to get it to rebind in IIS 7?
0
Daniel
Telerik team
answered on 31 Jul 2008, 03:33 PM
Hi Baatezu,

Excuse me if I am wrong, but could you please compare the publicKeyToken string in the error message and the one in the webconfig.

<assemblyIdentity name="Telerik.Web.UI" culture="neutral" publicKeyToken="121fae78165ba3d" />

Could not load file or assembly 'Telerik.Web.UI, Version=2008.1.619.20, Culture=neutral, PublicKeyToken=121fae78165ba3d4' or one of its dependencies

I tested this again and I confirm that it is working properly.

Kind regards,
Daniel
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
0
Baatezu
Top achievements
Rank 2
answered on 01 Aug 2008, 12:53 AM
*hangs head* I'm not sure if it's ME stupid, or IIS stupid... It works now.
I had to place the <runtime> tag at the VERY END of the file, the last entry before the </configuration> tag. One of those little things. Other than that, it seems to be functioning now.

Thanks for the help.
Param
Top achievements
Rank 1
commented on 29 Nov 2021, 08:56 AM

This seemed to work @Baatezu. Thanks!
Tags
General Discussions
Asked by
Baatezu
Top achievements
Rank 2
Answers by
Daniel
Telerik team
Baatezu
Top achievements
Rank 2
Share this question
or