Uninstall Trial, Install Dev, controls not showing

3 posts, 0 answers
  1. Fernando Jose
    Fernando Jose avatar
    2 posts
    Member since:
    Jul 2011

    Posted 26 Oct 2011 Link to this post

    I uninstalled the trial version before installing the dev. Created a new project solution when dev was installed, using F4, the controls are not showing up in the toolbox, try to use the telerik toolbox config, and choose the F4 option. The tool shows that the version in toolbox is the current one.I did this before and after reset the toolbox, and still not showing. try to repair the installation, and still not showing up, delete files from %localappdata%\Microsoft\VisualStudio\10.0\*.tbd, use the tool, and I see that the file for displaying the toolbox(toolbox.tbd), is different that the one that is used for reset after I run the config toolbox tool, but VS 2010 is not showing up the tools.

    Can you help?

    Fernando Gongora Sosa
  2. Aylin
    Aylin avatar
    75 posts

    Posted 27 Oct 2011 Link to this post

    Hello Fernando Jose,

    I am sorry to hear about the issues you are experiencing.

    Unfortunately, the Toolbox item registration is not entirely under our control. Since you have already tried using the toolbox configurator, resetting the toolbox and deleting the *.tbd files and it didn't work for you, I would suggest a workaround that typically resets the toolbox in terms of Telerik controls. Here are some steps we've identified as the most complete reset of the Toolbox.
    1. Close all Visual Studio instances
    2. Run Regedit
    3. Navigate to the following key: HKEY_LOCAL_MACHINE\SOFTWARE\(Wow6432Node\)Microsoft\VisualStudio\10.0\ToolboxControlsInstaller. Please note, the path should not contain the Wow6432Node on a 32-bit machine.
    4. Delete all the Telerik.Web.UI subkeys (if any exist)
    5. Navigate to the following key: HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\10.0\ToolboxControlsInstallerCache
    6. Delete all the Telerik.Web.UI subkeys (if any exist)
    7. Navigate to the following key: HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\10.0\ToolboxControlsInstaller
    8. Delete all the Telerik.Web.UI subkeys (if any exist)
    9. Navigate to the following key: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\VisualStudio\10.0\Packages\{2c298b35-07da-45f1-96a3-be55d91c8d7a}\Toolbox
    10. Update the value of the Default Items value (increase it by 1, make sure it is greater than 0)
    11. Start a Windows Explorer instance.
    12. Navigate to the following folder: %localappdata%\Microsoft\VisualStudio\10.0
    13. Delete all the *.tbd files (note, you would need to have the System and Hidden files visible to see the TBD files)
    14. Use the Telerik -> RadControls for ASP.NET AJAX -> ToolboxConfigurator menu in Visual Studio to add the distribution you need to the Toolbox
    15. Create a new ASP.NET AJAX project and drag and drop a RadControls item from the toolbox.
    16. Close Visual Studio, load your project and try dragging and dropping a RadControls item to a page.

    Let me know if that helps.

    Best Regards,
    Aylin Hyumet,
    the Telerik team

    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now
  3. Fernando Jose
    Fernando Jose avatar
    2 posts
    Member since:
    Jul 2011

    Posted 27 Oct 2011 Link to this post

    Thank you!
    I can see the controls on the toolbox now!

    Fernando Gongora
Back to Top