Unicode language displays as squares when exported to PDF

3 posts, 0 answers
  1. John Mann
    John Mann avatar
    38 posts
    Member since:
    Nov 2008

    Posted 19 Mar 2015 Link to this post

    I have a report that supports multiple languages. Most of them display and export to PDF correctly. But there are two that will display correctly in the ReportViewer, but when exported to PDF they display all the characters as empty squares. I'm using Arial Unicode MS as the report's base font. The two problem languages are Amharic and Tigrinya. They do display correctly if exported to Word or Excel. The properties of the PDF show that it is using the correct Unicode font. This is all taking place on my desktop development environment. I've checked all the language settings on my computer and read other threads here with a similar problem. None of the suggested solutions work. The report does work properly in English, Russian, French, Somali, Spanish, and Vietnamese.

    Anything else I can try?

    Thanks!
  2. John Mann
    John Mann avatar
    38 posts
    Member since:
    Nov 2008

    Posted 20 Mar 2015 Link to this post

    I have a work around for this problem. As I said before I was able to export this document to Word successfully in the problem languages. In Word it showed they were using the Arial Unicode MS font, so I didn't understand why Acrobat couldn't display them using that same font. I then exported them into rtf format (which also opened in Word) and here it showed that they were using a font called Nyala (Named after an African antelope). I modified the report to switch to this font when needed for one of these languages and everything works now. I also found if I inspected the text elements in the report viewer using the IE Developer Tools that it also showed the font as Nyala. Knowing that sooner could have saved me a lot of head-scratching.

    I hope this helps someone.
  3. Hinata
    Hinata avatar
    146 posts
    Member since:
    Dec 2013

    Posted 24 Mar 2015 in reply to John Mann Link to this post

    Hi John,

    Thanks for sharing this solution. Also could you share if you have tested fully embedding the fonts in the exported PDF and how did that work out?
Back to Top