This is a migrated thread and some comments may be shown as answers.

Unhandled exception at "Telerik.VSX.AssemblyDiscovery.AssemblyLister.Init"

5 Answers 248 Views
Installer and VS Extensions
This is a migrated thread and some comments may be shown as answers.
Telerik Admin
Top achievements
Rank 1
Telerik Admin asked on 17 Mar 2010, 02:22 PM
Update: You can use the attached Patch file (in the Telerik.Web.UI_2010_1_309_Hotfix.zip archive) to fix the problem too. Please, close all Visual Studio instances first.

Update:
This fix is already applied in the Q1 2010 SP1 release. You can download it from the downloads section of your Telerik account.

An error in the Q1 2010 release was identified recently.
Details:
When starting the Visual Studio IDE you get a screen with an unhandled exception in the Telerik.VSX.AssemblyDiscovery.AssemblyLister.Init method.
The problem goes away after a Visual Studio restart.

Fix:
  1. Close all the Visual Studio instances
  2. Download the attached archive and extract its content to the [RadControlsInstallFolder]\VSExtensions
  3. If you have Visual Studio 2010 installed, extract the archive content to the [VisualStudio2010InstallDir]\Common7\IDE\Extensions\Telerik\Telerik.Web.UI.VSPackage\2010.1.309 folder as well.
  4. Start Visual Studio again

5 Answers, 1 is accepted

Sort by
0
apb
Top achievements
Rank 1
answered on 22 Mar 2010, 10:25 AM
This is happening is VS2008 also -- see attached. I do not even install any 2010 components. Does this fix work for VS2008 also?

System.Exception was unhandled
  Message="Telerik.Web.UI.VSX.AssemblyDiscovery.AssemblyLister needs to be initialized only once."
  Source="Telerik.VSX"
  StackTrace:
       at Telerik.VSX.AssemblyDiscovery.AssemblyLister.Init()
       at Telerik.VSX.Helpers.UpdateChecker.VersionAvailabilityGetter_Complete(Object sender, EventArgs e)
       at Telerik.VSX.LatestVersionProcessing.BaseMonitoredProcess`1.DoAsyncJobAndRaiseCompleteEvent()
       at System.Threading.ThreadHelper.ThreadStart_Context(Object state)
       at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
       at System.Threading.ThreadHelper.ThreadStart()
  InnerException:
0
Erjan Gavalji
Telerik team
answered on 22 Mar 2010, 01:00 PM
Hi apb,

Yes, the fix works for VS2008, VS2005. The specific thing is for VS2010 only, where the file needs to be extracted in a specific folder.

Kind regards,
Erjan Gavalji
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
0
TonyG
Top achievements
Rank 1
answered on 31 Mar 2010, 08:10 PM
Fix confirmed for VS2008 with Telerik.Web.UI.VSX.dll extracted to:
C:\Program Files\Telerik\RadControls for ASP.NET AJAX Q1 2010\VSExtensions
Thanks team - this was getting annoying.  I'm glad the solution came quickly.
0
marco polo
Top achievements
Rank 1
answered on 07 Jun 2010, 04:39 PM
This fix worked for me on VS2008. Thanks
0
TonyG
Top achievements
Rank 1
answered on 07 Jun 2010, 07:32 PM
I feel stupid but I stumbled on this issue when I downloaded (I believe) build 509 and got the same issue and then filed a support ticket because I forgot about this thread, and searching with all logical keywords didn't help.

The official response was to uninstall the prior release (I used Add/Remove programs) and install the latest release, rather than just assigning assemblies from downloads to new projects.  This worked as expected.  (Though as always we need to manually clean out the VS toolbox.)
Tags
Installer and VS Extensions
Asked by
Telerik Admin
Top achievements
Rank 1
Answers by
apb
Top achievements
Rank 1
Erjan Gavalji
Telerik team
TonyG
Top achievements
Rank 1
marco polo
Top achievements
Rank 1
Share this question
or