This is a migrated thread and some comments may be shown as answers.

unable to indent line by line

3 Answers 30 Views
Editor
This is a migrated thread and some comments may be shown as answers.
Curious
Top achievements
Rank 1
Curious asked on 03 Dec 2018, 05:46 PM

I just took over an app that is using the Editor control and users are unable to indent line by line. When they try to indent to indents everything in the box. I have to go to the HTML tab and remove the <p> text</p> tags to have it indent line by line. Is there a fix for this somewhere or do we need to upgrade? It's happening with IE 11.

 

The Telerick.Web.UI dll we are referencing is version:

2011.1.413.35

runtime version is: v2.0.50727

 

I have the app rendering in IE 9 mode in IE 11, however, it's still not working correctly with the formatting pieces

3 Answers, 1 is accepted

Sort by
0
Rumen
Telerik team
answered on 04 Dec 2018, 03:38 PM
Hi Mike,

For this pretty old version you may want to apply the custom solution provided at RADEditor Indent to use padded div instead of Blockquote.

Fort the newer versions, please note that RadEditor user experience was changed to be as much close to MS Word and the desktop rich text editors as possible . They indent entire paragraphs (i.e. block elements) so we are having the same behavior now. You can test this in MS Word for example. Details about this change and how to revert it are available here: http://www.telerik.com/help/aspnet-ajax/editor-inline-and-block-commands-behavior-change.html.

Best regards,
Rumen
Progress Telerik
Get quickly onboarded and successful with your Telerik and/or Kendo UI products with the Virtual Classroom free technical training, available to all active customers. Learn More.
0
Curious
Top achievements
Rank 1
answered on 05 Dec 2018, 01:35 PM
This only works in Chrome, is there something different for IE 11? I would think it would be the same across browsers, however, I'm only able to get this working on Chrome
0
Rumen
Telerik team
answered on 10 Dec 2018, 11:04 AM
Hi Mike,

What I would suggest is setting the NewLineBr property to false, thus the editor will insert paragraph tag on every enter-key press and you will be able to apply the indentation and alignment per line.

Additionally, if you want to reduce the extra space between the paragraph blocks inside the editor's content area, you should set a global CSS paragraph style in your page with margin: 0px, e.g.

  <style>
       P { margin: 0px }
  </style>
    ...  
<telerik:RadEditor ID="RadEditor1" NewLineBr="false" runat="server"></telerik:RadEditor>

The solution is explained in this KB article: Applying indentation or alignment per line.
 

Best regards,
Rumen
Progress Telerik
Get quickly onboarded and successful with your Telerik and/or Kendo UI products with the Virtual Classroom free technical training, available to all active customers. Learn More.
Tags
Editor
Asked by
Curious
Top achievements
Rank 1
Answers by
Rumen
Telerik team
Curious
Top achievements
Rank 1
Share this question
or