Unable to display the demo report in a web api project

4 posts, 0 answers
  1. Ammon
    Ammon avatar
    3 posts
    Member since:
    May 2014

    Posted 10 Feb 2015 Link to this post

    Hello,

    We have followed the instructions for creating a new report via the quick start wizard instructions.  We continue to get a 404 error stating the Requested URL   http://localhost:55677/Controllers/api/reports/clients cannot be found. 

    Is there a specific set of steps to configure a web api project to use the default reporting out-of-the-box?

    Thanks!
  2. Ammon
    Ammon avatar
    3 posts
    Member since:
    May 2014

    Posted 10 Feb 2015 in reply to Ammon Link to this post

    Specifically we are using Web API 5.2.2 in VS 2013.
  3. Ammon
    Ammon avatar
    3 posts
    Member since:
    May 2014

    Posted 11 Feb 2015 in reply to Ammon Link to this post

    We figured it out.  You just have to add the new reporting template at the project level, not to a sub-directory for the mapping to work out. 
  4. Stef
    Admin
    Stef avatar
    3610 posts

    Posted 12 Feb 2015 Link to this post

    Hello Ammon,

    I am glad to hear the issue is resolved.

    In general, the service must be set and tested per How To: Add Telerik Reporting REST Web API to Web Application. Then at the client relative paths to the service, CSS and JS files, and the viewer HTML template must be checked if they map correctly to the base path. For more details check ASP.NET Web Site Paths (msdn).

    Regards,
    Stef
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
Back to Top