Unable to add views

3 posts, 0 answers
  1. David
    David avatar
    138 posts
    Member since:
    Jan 2011

    Posted 10 Feb 2020 Link to this post

    I am trying to start a Asp.Net.Core 3.1 core project.  I used the default Grid based project template.  That all went off without a hitch.  The default template delivers a workable starting project.

    I then attempted to add my first view.  Right clicked on item, selected "add VIew".  The system responds with the message: "There was an error running the selected code generator:  The local source "C:\Program Files (x86)\Progress\Telerik UI for ASP.NET Core R3 2019\wrappers\aspnetcore\Binaries\AspNet.Core" does not exist.

    The message is accurate as the referenced path does not exist.  My system has Telerik UI for ASP.NET Core R1 2020 not the referenced R3 2019 folder.

    To the best of my knowledge my project has no reference other than 2020 versions.  Effectively I am blocked from adding a view via the "add View" option.  If I knew where that reference was I might be able to correct things.

    Anyone have any ideas on what I am forgetting to do?  I have tried all the options, partial view, use or do not use layout pages, reference or do not reference script pages, no option works.

     

     

  2. Ivan Danchev
    Admin
    Ivan Danchev avatar
    2184 posts

    Posted 13 Feb 2020 Link to this post

    Hello David,

    The error message shows that the project tries to access an old package source.

    Try the following: in VS go to: Tools  ->  Nuget Package Manager -> Package Manager Settings -> Package Source and remove the old package source, if it is listed.

    Additionally, open the NuGet.Config file (in the application folder at the same level as the solution's .sln file) in a text editor. If an old package source is present, remove it.

    If you still get the error, .zip the project and send it our way for further review.

    Regards,
    Ivan Danchev
    Progress Telerik

    Get quickly onboarded and successful with Telerik UI for ASP.NET Core with the dedicated Virtual Classroom technical training, available to all active customers.
  3. David
    David avatar
    138 posts
    Member since:
    Jan 2011

    Posted 13 Feb 2020 in reply to Ivan Danchev Link to this post

    You nailed it.  My package sources include a "Telerik Feed" of my creation (https://nuget.telerik.com/nuget/) and two I never added.  Those appear to be the source of my problems.  I unchecked "Kendo Mvc 2019.3.917" and "Telerik UI for ASP.NET Core 2020.1.114" and my problems went away.  I re-installed the now missing Telerik package, from my created feed, and now everything compiles, or adds new views/controllers as required.

     

    I guess the root "bug" (if it is a bug), is the magical addition of package sources which apparently do not get upgraded.

Back to Top