This is a migrated thread and some comments may be shown as answers.

Trouble with Q2 2008 installation

1 Answer 19 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Adam
Top achievements
Rank 1
Adam asked on 23 Sep 2008, 12:02 AM

I installed the Q2 2008 Rad ASP.NET AJAX controls, and based on this page, I figured it would create a single Telerik.Web.Ui.dll in the /bin directory. Instead, I got a /NET1 and /NET2 directory, each of which has a /bin beneath it with all a separate dll for each control.

The effect of this is that, when I went to add a grid to a page from the toolbox, it tried to use the RadGrid.Net2 assembly rather than the Telerik.Web.UI. Also, I am unable to use a popup edit form on that grid, since that assembly seems to have no knowledge of popup mode (only "EditForms" and "InPlace"). I did have an older version of the controls installed previously, so it could be a problem with my GAC, but I've since uninstalled them, leaving only Q2 2008.

Does anyone have an explanation for what I am doing wrong, and how I might fix it?

1 Answer, 1 is accepted

Sort by
0
Sebastian
Telerik team
answered on 23 Sep 2008, 07:30 AM
Hi Adam,

It seems that you installed the Classic version of RadControls for ASP.NET on your machine and this is the reason why you get the Net1/Net2 folders and the /bin folders with the individual controls assemblies. How to migrate to RadControls for ASP.NET AJAX you can see from the following KB article on our site.

Best regards,
Stephen
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Tags
General Discussions
Asked by
Adam
Top achievements
Rank 1
Answers by
Sebastian
Telerik team
Share this question
or