Treeview with PageAdapter

2 posts, 0 answers
  1. Som
    Som avatar
    35 posts
    Member since:
    Oct 2007

    Posted 06 Jun 2011 Link to this post

    Application Environment: .net Framework 4.0, C#, ASP.net, Telerik RadControls for ASP.NET Ajax version 2010.3.1317.40.

    We have been using the Treeview control in our application for a while. We load a lot of nodes in the Tree and in order to improve the performance we decided to use the PageAdapter to maintain the viewstate on the server instead of the client. It significantly improved the performance of the Tree but sometimes the Tree does not load on postbacks and refresh. We have the Tree in the leftpane of a frame set and on postbacks and refresh the the left pane stays blank. On refresh it loads again fine. It does not happen consistently and there is no set sequence of events to replicate the behavior. I was wondering if anyone has experienced this behavior before. Please let us know of any solutions, suggestions or ideas.

    Thanks
    Som
  2. Nikolay Tsenkov
    Admin
    Nikolay Tsenkov avatar
    734 posts

    Posted 09 Jun 2011 Link to this post

    Hello Som,

    Could you, please, open a support ticket and send us a sample reproducing the problem you experience?
    Please, extract only the relevant to the issue code in a runnable sample, so we can resolve the cause for the problem faster.


    Regards,
    Nikolay Tsenkov
    the Telerik team

    Browse the vast support resources we have to jump start your development with RadControls for ASP.NET AJAX. See how to integrate our AJAX controls seamlessly in SharePoint 2007/2010 visiting our common SharePoint portal.

Back to Top