This is a migrated thread and some comments may be shown as answers.
TreeView keyboard navigation selects invisible nodes
1 Answer 4 Views
This is a migrated thread and some comments may be shown as answers.
أشرف
Top achievements
Rank 1
أشرف asked on 28 Jul 2015, 10:55 AM

Greetings,

 I've already filed a bug report about this here a couple of weeks ago but no one replied.

Please read the details in the report.

1 Answer, 1 is accepted

Sort by
0
Dimitar
Telerik team
answered on 31 Jul 2015, 07:07 AM
Hi,

Thank you for the detailed reproduction steps. I was able to reproduce the described behavior.

Fortunately, you could easily avoid this keyboard navigation behavior by applying set_enabled(false) to the respective item. Thus, keyboard navigation would skip the item and jump to the next one. You could combine this setting with hiding the item and you should observe the desired behavior.

Regards,
Dimitar
Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Asked by
أشرف
Top achievements
Rank 1
Answers by
Dimitar
Telerik team
Share this question
or