This is a migrated thread and some comments may be shown as answers.

Toolbars are not showing correctly when using a custom tools file

1 Answer 32 Views
WebParts for SharePoint
This is a migrated thread and some comments may be shown as answers.
Peterson
Top achievements
Rank 1
Peterson asked on 28 Oct 2008, 08:16 PM
I have a text area where I only want to show three tools - unlink, link and document manager.  I create a custom toolsfile.xml and use that in ToolsFile attribute of the control.  I also set the display to Default instead of ShowOnFocus. 

With Firefox and Safari, only ShowOnFocus will show the toolbar correctly.  If I used default, the tools are not shown.  (Using Firebug, I saw that the area for the tools are too small...)  With IE, neither ShowOnFocus nor Default will show any of the tools correctly.

We have RadEditor for MOSS 5.0.1.0 running.  I have screenshots captured but I can't see how I can upload them here.  Please contact me if you need the screenshots.  Thanks.

In ASPX page:
    <div id="divRelatedInfo" class="cmpwrapper">
        <div class="cmpheader"></div>
        <div class="cmpcontentbg">
            <div class="cmpcontent">
                <img id="Img1" runat="server" src="relatedInfo.gif">" alt="Related Icon" />
                <span class="cmptitle">Related Info</span><br/>
                <hr/>                
                <span id="RelatedInfoContent"><radE:RadHtmlField ToolsFile="~/_wpresources/RadEditorSharePoint/5.0.1.0__1f131a624888eeed/Resources/ToolsFileRelatedInfo.xml" id="_migidRelatedInfo"  FieldName="Related_Info" runat="server" AllowImages="False" DisplayWidth="150px" /></span>
            </div>
        </div>
        <div class="cmpfooter"></div>
    </div>

ConfigFile.Xml
<configuration>
  <property name="AllowThumbGeneration">True</property>
  <property name="ConvertToXhtml">True</property>
  <property name="EnableDocking">True</property>
  <property name="ShowHtmlMode">True</property>
  <property name="ShowPreviewMode">False</property>
  <property name="StripAbsoluteAnchorPaths">False</property>
  <property name="StripAbsoluteImagesPaths">False</property>
  <property name="ToolbarMode">ShowOnFocus</property> Changed to Default too...
  <property name="ToolsWidth">800px</property>
  <property name="Skin">Default2006</property>
  <property name="ImagesPaths"><item>/SiteCollectionDocuments</item></property>
</configuration>

CustomToolsFile.Xml
<root>
    <tools>
        <tool name="MOSSLinkManager" shortcut="CTRL+K" />
        <tool name="Unlink" shortcut="CTRL+SHIFT+K" />
        <tool name="DocumentManager"  />
    </tools>
    <contextMenus>
        <contextMenu forElement="*">
            <tool name="Cut"/>
            <tool name="Copy"/>
            <tool name="Paste"/>
        </contextMenu>
    </contextMenus>
</root>

1 Answer, 1 is accepted

Sort by
0
Peterson
Top achievements
Rank 1
answered on 29 Oct 2008, 07:12 PM
Found the issue.  The div tag which contains the toolbar is setting the width to 100%, which is overriding the rad tool's width setting.
Tags
WebParts for SharePoint
Asked by
Peterson
Top achievements
Rank 1
Answers by
Peterson
Top achievements
Rank 1
Share this question
or