TimeView Interval not displaying correct while Interval is correct

1 posts, 0 answers
  1. Andre Speek
    Andre Speek avatar
    1 posts
    Member since:
    Feb 2015

    Posted 12 Sep Link to this post

    Hi,

    In short, I've set the Interval for the RadDateTimePicker to 15 minutes from code. It looks like this is not working since the TimeView shows the default interval in Hours. However, when picking one of the Hours, the selected value reveals it returns the expected value.

    For example, if you click on 01:00 hrs, it returns 00:15. Click on 02:00, it returns 00:30.

    Is this a bug? Or am I overlooking something here? Thanks in advance!

     

    Here's the code for the DateTimePicker in the page:

    <telerik:RadDateTimePicker ID="radDateTimeStart" Skin="MetroTouch" DatePopupButton="False" runat="server"
            AutoPostBack="False" ShowPopupOnFocus="True" MinDate="01/01/1000" MaxDate="01/01/3000"
            Visible="False" CssClass="SilverTextInput">
        <Calendar ID="calCombiStart" runat="server">
            <SpecialDays>
                <telerik:RadCalendarDay Repeatable="Today" ItemStyle-CssClass="rcToday" />
            </SpecialDays>
        </Calendar>
        <TimeView ID="timeCombiStart" runat="server" Columns="4" TimeFormat="HH:mm" ShowHeader="false"></TimeView>
    </telerik:RadDateTimePicker>

     

    And here's how it is set from code, in an ASP:Repeater

    RadDateTimePicker radDateTimeStart = (RadDateTimePicker)e.Item.FindControl("radDateTimeStart");
    RadTimeView timeCombiStart = radDateTimeStart.TimeView;
     
    TimeSpan t = new TimeSpan(0, 0, 15, 0, 0);
    timeCombiStart.Interval = t;
    timeCombiStart.Columns = 4;

     

    Do note: I also tried setting the Columns value from code to be sure I was in the right Control which proved it was.

    For clarification I took a screencam from the behavior as described: https://www.youtube.com/watch?v=mWCEnbWrVoM

Back to Top