The new Browser Link feature in VS 2013 is causing an error when DetailTable of Hierarchy RadGrid is expanded.

7 posts, 0 answers
  1. Telerik Admin
    Telerik Admin avatar
    1572 posts
    Member since:
    Oct 2004

    Posted 12 Dec 2013 Link to this post

      We have discovered an issue when expanding RadGrid DetailTable in case the Browser Link of VS 2013 is enabled. The issue is actually a generic internal problem in the VS feature and affects the RadGrid control with the following error:

    “JavaScript runtime error: Syntax error, unrecognized expression: unsupported pseudo: 0_0”

      The issue is known bug in jQuery which is internally used in the Browser Link functionality. When selecting elements which contains ":" in its id, jQuery does not return element. The reason for the problem is that jQuery has some predefined pseudo-selectors and “:00” for example is not a valid selector.

      The Browser Link script tries to find our detail tables elements by its id (the detail table id contains ":"), jQuery does not return element and the Browser Link scripts throws an error that the character sequence is not recognized.

      As this issue is still not fixed in the latest version of jQuery the only workaround for now is to disable the Browser Link feature in VS 2013.

  2. StringTheory
    StringTheory avatar
    8 posts
    Member since:
    Dec 2006

    Posted 11 Mar 2014 in reply to Telerik Admin Link to this post

    Thanks for this info. When this bug is fixed in a forthcoming jquery version, could someone post here to help others who get the error.  Also to save time in finding how to disable the browser link, you don't need to go looking through all the VS config settings. In your VS2013 IDE, locate the down-arrow selector just to the right of the refresh icon, located between the browser selector and the Debug/Release drop-down list. Click the down-arrow and un-select the option: "Enable Browser Link". MSDN also notes two other ways to achieve this setting change via code, including:

    1. Set appSetting “vs:EnableBrowserLink” to “false ““. This will  disable Browser Link.

    2. Set debug= false in web.config file.

    Hope this saves someone some time.

  3. Maria Ilieva
    Maria Ilieva avatar
    4017 posts

    Posted 14 Mar 2014 Link to this post

    Hi Steve,

    Thank you for commenting the post and provide easiest option for modifying the problematic VS setting.

    As soon as we have confirmation that the mentioned issue is fixed we will update the thread with this information.

    Maria Ilieva

    DevCraft Q1'14 is here! Watch the online conference to see how this release solves your top-5 .NET challenges. Watch on demand now.

  4. Paul J
    Paul J avatar
    101 posts
    Member since:
    Nov 2008

    Posted 20 Aug 2014 Link to this post

    so this issue caused me many hours and much pain. Dealing with an old application that uses an old telerik library. other programmer upgrade the project to VS 2013 a month ago, and started seeing the script error earlier this week but had no idea why. fortunately I Googled the right thing finally and found this post. turning off the "Enable browser link" and now is working. Just wish I could get my lost hours back...
  5. Shivam
    Shivam avatar
    5 posts
    Member since:
    Mar 2015

    Posted 21 Sep 2015 in reply to Telerik Admin Link to this post

    <add key ="vs:EnableBrowserLink" value="false"/>
     Thanks a lot. It worked.
  6. Moon
    Moon avatar
    250 posts
    Member since:
    Apr 2008

    Posted 24 Nov 2015 Link to this post

    This is an issue in VS2015 also. I just installed the WebEssentials and it started erroring on my RadWindows popups.

    Unhandled exception at line 37, column 59140 in http://localhost:64250/5899e8865f1844aba876e40dbab18311/browserLink

     I tried turning it off via Tools/Options, but that not work. still errored. Adding the key did turn it off:

    <add key ="vs:EnableBrowserLink" value="false"/>


    But this is 2 years later, wondering why it's still an issue.



  7. Maria Ilieva
    Maria Ilieva avatar
    4017 posts

    Posted 25 Nov 2015 Link to this post

    Hello Nannette,

    Note that the mentioned problem is actually a bug in JQuery used in the BrowserLink feature. As the JQuery used in the feature for VS 2015 still behaves in this way you should disabled the BrowserLink for avoiding this issue.

    Maria Ilieva
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top