This is a migrated thread and some comments may be shown as answers.

The HTTP verb POST used to access path '/virtual/' is not allowed.

6 Answers 110 Views
Grid
This is a migrated thread and some comments may be shown as answers.
Richard Weeks
Top achievements
Rank 2
Richard Weeks asked on 06 Feb 2012, 07:14 AM
I am using a RadGrid and capturing the client click of a row through OnItemCommand. I receive the error:
  • The HTTP verb POST used to access path '/virtual/' is not allowed.

Code (simplified):
protected void Grid_OnItemCommand(object sender, GridCommandEventArgs e)
{
    ...
    Response.Redirect("~/Page.aspx?id=" + id, false);
    ...
}

I think the issue is that the landing page is at the root of the virtual directory. So the postback from the grid is going to /virtual/ and not /virtual/Default.aspx. I think IIS doesn't like the lack of a page.

How do I stop these errors when posting back in a grid to a default document? I can't tell users to type in a fully qualified URL.

Richard

6 Answers, 1 is accepted

Sort by
0
Tsvetoslav
Telerik team
answered on 07 Feb 2012, 02:46 PM
Hi Richard,

Have you tried setting the action property of your form tag to the default page in your root directory: Default.aspx as far as I understand?

Greetings, Tsvetoslav
the Telerik team
Sharpen your .NET Ninja skills! Attend Q1 webinar week and get a chance to win a license! Book your seat now >>
0
Richard Weeks
Top achievements
Rank 2
answered on 08 Feb 2012, 12:12 AM
Hi, the form tags are set in the master page and used for all pages.

Richard
0
Tsvetoslav
Telerik team
answered on 08 Feb 2012, 12:10 PM
Hi Richard,

That's all right - could you try it for the form tag on the master page? 

Greetings,
Tsvetoslav
the Telerik team
Sharpen your .NET Ninja skills! Attend Q1 webinar week and get a chance to win a license! Book your seat now >>
0
Richard Weeks
Top achievements
Rank 2
answered on 14 Feb 2012, 06:06 AM
Hi,

I fixed the issue (I think) using information from this post:

http://www.telerik.com/community/forums/aspnet-ajax/ajax/net-version-problem.aspx

Is that a correct fix? Is there anything I should be aware of?

Our application is quite large and I worry about introducing further breaking changes,

Richard
0
Tsvetoslav
Telerik team
answered on 14 Feb 2012, 08:36 AM
Hi Richard,

Both the web.config solutions (in case you are using RadCompression) and the Page_Load code statement setting the form's action property are viable and correct.
 
Regards,
Tsvetoslav
the Telerik team
Sharpen your .NET Ninja skills! Attend Q1 webinar week and get a chance to win a license! Book your seat now >>
0
Ram
Top achievements
Rank 1
answered on 28 Aug 2019, 02:43 PM
Add an index.htm with below re-direct lines

<html>
  <head>
    <meta http-equiv="Refresh" content="0; url=Default.aspx" />
  </head>

</html>
Tags
Grid
Asked by
Richard Weeks
Top achievements
Rank 2
Answers by
Tsvetoslav
Telerik team
Richard Weeks
Top achievements
Rank 2
Ram
Top achievements
Rank 1
Share this question
or