This is a migrated thread and some comments may be shown as answers.

TelerikModalOverlay

4 Answers 187 Views
Window
This is a migrated thread and some comments may be shown as answers.
Guss
Top achievements
Rank 2
Guss asked on 04 May 2008, 11:36 PM
How do I change the background color of the modaloverlay. The current style of TelerikModayOverlay class background-color is #aaaaaa, which 50% opacity. This makes the the back window lighter. I would like to make the color #000 so that the overlay "dim" makes the back window darker.

I would prefer not to create a whole custom skin, just to be able to modify one property.

4 Answers, 1 is accepted

Sort by
0
Guss
Top achievements
Rank 2
answered on 05 May 2008, 10:02 AM
Also - the default z-index of the overlay is 2000. That is not heigh enough to cover some of your other default z-indices. Example: It does not cover the radMenu, using defaults as out of the box.
0
Accepted
Georgi Tunev
Telerik team
answered on 08 May 2008, 10:54 AM
Hello Guss,

To achieve this you need to override the default style with your own and use the !important directive. For example:

<head runat="server">
    
<title>Untitled Page</title>
    
<style type="text/css">
    
.TelerikModalOverlay
    
{
        filter
: progid:DXImageTransform.Microsoft.Alpha(style=0,opacity=10) !important; 
        background
: red !important;
        opacity
: .1 !important;
        -moz-opacity
: .1 !important;
    
}
    </
style>
</head>

I hope this helps.

Kind regards,
Georgi Tunev
the Telerik team

Instantly find answers to your questions at the new Telerik Support Center
0
Nick
Top achievements
Rank 1
answered on 26 May 2008, 08:48 PM
Oke next problem for me ...

I want modal windows but i dont dont want any modal background opacity inside my enviroment ... no i did this ... in my custom skin:

.TelerikModalOverlay
{
     filter: none  !important;
    background: none !important;
    opacity: none !important;
    -moz-opacity: none !important;
}

this works fine for my first opened radwindow ... but no i'm opening another radwindow from the already opened radwindow... and this sets the background opacity inside this radwindow to 10% or something ... any idea how to fix this problem ?
0
Svetlina Anati
Telerik team
answered on 28 May 2008, 03:17 PM
Hi Nick,

I was not able to reproduce your problem, furthermore when I remove the background as you have done the RadWindow loses its modality and the page is accessible.

You also say that you are using a custom skin and this means that you have set the EnableEmbeddedSkins property to false - in this case you do not need to add the keyword !important because you do not have to override the default skin. 

I suppose that the difference comes from the custom settings you have made in your project and the ones I have in my testing setup.

Would you please open a new support ticket and send me a sample, working example which reproduces the problem along with a detailed explanation of the desired behavior? Once I receive it I will do my best to help.

Sincerely yours,
Svetlina
the Telerik team

Instantly find answers to your questions at the new Telerik Support Center
Tags
Window
Asked by
Guss
Top achievements
Rank 2
Answers by
Guss
Top achievements
Rank 2
Georgi Tunev
Telerik team
Nick
Top achievements
Rank 1
Svetlina Anati
Telerik team
Share this question
or