Telerik.Web.Design.dll issue

3 posts, 0 answers
  1. Marco Basta
    Marco Basta avatar
    6 posts
    Member since:
    Mar 2006

    Posted 16 Jun 2009 Link to this post

    I upgraded RadControls for ASP.NET AJAX from Q3 2008 to Q1 2009 and started having design time error message "Error Creating Control - xxxxx ... Could not load file or assembly 'Telerik.Web.UI, version=2009.1.527.35,,,," I upgraded my Visual Studio from a professional Edition to the latest (Jan 31, 2009) 2008 Developer Edition. It worked for a few days and then I started getting the error again. I tried folowing one of the recommended suggestions below w/ no success. 

    1. Install SP1 of Visual Studio 2008 (Didn't work)

    2. Bin-deploy the design-time assembly (Cannot remove the GAC dll. says: Assembly 'Telerik.Web.Design' could not be uninstalled because it is required by other applications) 
              * Add a reference to Telerik.Web.Design.dll to your web site or application
              * Remove Telerik.Web.Design.dll from the GAC
              * Restart Visual Studio
     3. GAC-deploy the control library assembly  (Not an option)
              * Add Telerik.Web.UI.dll in the GAC
              * Remove Telerik.Web.UI.dll from your bin folder
              * Restart Visual Studio

    Please help. I already waisted 2 days on this and the best thing I can find are the suggestions above.

  2. Atanas Korchev
    Atanas Korchev avatar
    8462 posts

    Posted 17 Jun 2009 Link to this post

    Hello Marco Basta,

    Installing Visual Studio 2008 SP1 should resolve this issue. Make sure the versions of Telerik.Web.Design.dll and Telerik.Web.UI.dll are exact match.

    You can check this blog post for additional info.

    Kind regards,
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. Udith
    Udith avatar
    1 posts
    Member since:
    Sep 2012

    Posted 27 Feb 2013 Link to this post

    I have the same Issue I have tried several way to remove it but I couldn't able finally I've browse "C:\Windows\assembly\GAC_MSIL" path and Delete the dll its work for me :)
Back to Top