Telerik UI for ASP.NET AJAX (2010.1519) using lower version of jQuery

0 Answers 57 Views
Ajax AjaxLoadingPanel AjaxPanel ComboBox DatePicker Grid Window
kanimozhi
Top achievements
Rank 1
kanimozhi asked on 08 May 2023, 12:27 PM

Dear Telerik Team,

We have purchased Telerik UI for ASP.NET AJAX UI 2010.1519. Now we are facing vulnerable issues as it is using jQuery 1.4.2.

One of the Telerik doc tells that

When Telerik upgraded jQuery version to 3.3.1, it faces incompatibilities with the MS AJAX framework and its __doPostBack() method. Due to which, Telerik downgraded jQuery version Telerik UI for ASP.NET AJAX R1 2019 - present are using a modified jQuery version 1.12.4 that includes security vulnerability backport fixes.

Is there a fix to overcome this issue other than upgrading the Telerik version to 2019 or greater?

Rumen
Telerik team
commented on 09 May 2023, 06:32 AM

Hi Kanimozhi,

Even if you disable the built-in jQuery and configure the controls to use an external newer version of jQuery, you should be aware that version 2010.1519 is vulnerable to some critical vulnerabilities that cannot be fixed. That is why it is strongly recommended to upgrade to at least 2020.1.114 to protect your server. You can find more information at:

No answers yet. Maybe you can help?

Tags
Ajax AjaxLoadingPanel AjaxPanel ComboBox DatePicker Grid Window
Asked by
kanimozhi
Top achievements
Rank 1
Share this question
or