This is a migrated thread and some comments may be shown as answers.

Telerik Report After Deployment to IIS 7.5 Not Rendering on IE

1 Answer 65 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Yazan
Top achievements
Rank 1
Yazan asked on 17 Sep 2013, 10:30 PM
I've already checked out most of the online references regarding this problem, I'm using the latest version: Q2 2013 SP1. I'm running .NET 4.0

As described in the title, the Report is rendering on Locahost but not on the server. And I noticed that that's only happening in IE (I tried IE 10)

Note that I'm using RadWindow to host the ReportViewer

I already registered the following in Web.config:

<configSections>
    <section name="Telerik.Reporting" type="Telerik.Reporting.Processing.Config.ReportingConfigurationSection, Telerik.Reporting,       Version=7.1.13.802, Culture=neutral, PublicKeyToken=a9d7983dfcc261be" allowLocation="true" allowDefinition="Everywhere" />
</configSections>
 
<controls>
    <add tagPrefix="TelerikReportViewer" assembly="Telerik.ReportViewer.WebForms, Version=7.1.13.802, Culture=neutral, PublicKeyToken=a9d7983dfcc261be" namespace="Telerik.ReportViewer.WebForms" />
    <add tagPrefix="CR" assembly="CrystalDecisions.Web, Version=13.0.2000.0, Culture=neutral, PublicKeyToken=692fbea5521e1304" namespace="CrystalDecisions.Web" />
</controls>
 
<httpHandlers>
    <add type="Telerik.ReportViewer.WebForms.HttpHandler, Telerik.ReportViewer.WebForms, Version=7.1.13.802, Culture=neutral, PublicKeyToken=a9d7983dfcc261be" path="Telerik.ReportViewer.axd" verb="*" />
</httpHandlers>
 
<system.webServer>
    <handlers accessPolicy="Read, Execute, Script">
        <add name="Telerik.ReportViewer.axd_*" type="Telerik.ReportViewer.WebForms.HttpHandler, Telerik.ReportViewer.WebForms, Version=7.1.13.802, Culture=neutral, PublicKeyToken=a9d7983dfcc261be" path="Telerik.ReportViewer.axd" verb="*" preCondition="integratedMode" />
    </handlers>
</system.webServer>

with no luck so far.

Thanks,

1 Answer, 1 is accepted

Sort by
0
Stef
Telerik team
answered on 20 Sep 2013, 05:53 PM
Hi Yazan,

Please try the following:
  • Add meta tag forcing Internet Explorer to render the page containing ReportViewer with the highest possible Standard mode, not Compatibility View:
    <meta http-equiv="X-UA-Compatible" content="IE=edge">
  • Try to resize the whole DOM tree as suggested by my colleague in the this forum post;

If you need further help, please elaborate what is the scenario, how is the ReportViewer displayed on screen, what part of the report is not shown - only the report area or including the viewer.

Regards,
Stef
Telerik

Have you tried the new visualization options in Telerik Reporting Q2 2013? You can get them from your account.

Tags
General Discussions
Asked by
Yazan
Top achievements
Rank 1
Answers by
Stef
Telerik team
Share this question
or