This is a migrated thread and some comments may be shown as answers.

Telerik Editor Issue

9 Answers 132 Views
WebParts for SharePoint
This is a migrated thread and some comments may be shown as answers.
Amit
Top achievements
Rank 1
Amit asked on 02 Jul 2010, 12:41 PM
Hi,

We are facing some issue while creating the page with telerik editor. Screen shot also attached for the same error below mentioned.
I am getting "Click Auto Correct on the toolbar to remove invalid content or formatting". I am not able to figure out where auto correct icon is in toolbar. Will apreciate if someone can help me on that.



9 Answers, 1 is accepted

Sort by
0
Stanimir
Telerik team
answered on 06 Jul 2010, 12:48 PM
Hello Amit,

Could you provide me with some additional information so I will be able to reproduce the issue?
Inform me exactly which version of RadEditor for MOSS are you using? Send me the contents of the ConfigFile.xml, which is located in the /Program Files/Common Files/Microsoft Shared/web server extensions/wpresources/RadEditorSharePoint/5.x.x.0__1f131a624888eeed/Resources/ folder. Also provide me with the HTML content, which is causing the issue.

Greetings,
Stanimir
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
0
Amit
Top achievements
Rank 1
answered on 06 Jul 2010, 02:26 PM
Hi,

The Version we are using is:
We are using the Version RadEditorMOSS_5_7_3_Trial.

The Content which is creating problem:

<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=us-ascii">
</head>
<body>
<div id="mainContent" name="mainContent" style="margin-top:15px; margin-left:15px">
<table height="20" cellspacing="0" cellpadding="0" width="379" border="0">
<tbody>
<tr>
<td class="lob-sb1-chromeHeader">Open a ticket</td>
</tr>
</tbody>
</table>
<br>
<table cellspacing="0" cellpadding="1" width="379" border="0">
<tbody>
<tr>
<td valign="top" width="11"><img height="13" width="9"></td>
<td valign="top" width="100%"><strong><span class="epi-fontLg">Issues/Performance Issues</span></strong>
<ol style="margin-top:1px">
<li>Go to the homepage - <a class="spi-spi-lefthand1-cdt3-titlelink" title="Help" href="Test.aspx?C=33a585ec205b4e75a1fb448e1e22928f&amp;URL=http%3a%2f%2ftest%2f" target="_blank">
http://Google.com</a> </li><li>Under the &quot;Contact Us&quot; section, click on &quot;Open a Issue Online&quot; </li><li>Enter Login ID and Password </li><li>Enter description of issue/problem within the Description Box; also, add the following text &quot;Issue  is for the Attention of the Test&quot;
</li><li>Validate your Login ID </li><li>Click on &quot;No Thanks - Submit Ticket&quot; </li></ol>
<p>&nbsp;</p>
For those that <b>DO NOT</b> have access to &quot;Open a ISSUE  Online,&quot; <br>
- Enter your SID and select option(s) 1, 3, 6<br>
- Raise a Problem Ticket for the attention of the &nbsp;&nbsp;TEST workgroup</td>
</tr>
</tbody>
</table>
<table>
<tbody>
<tr valign="top">
<td width="379"><br>
<table height="20" cellspacing="0" cellpadding="0" width="379" border="0">
<tbody>
<tr>
<td class="lob-sb1-chromeHeader">Contact Us</td>
</tr>
</tbody>
</table>
<br>
<table cellspacing="0" cellpadding="1" width="100%" border="0">
<tbody>
<tr>
<td valign="top" width="11"><img height="13" width="9"></td>
<td valign="top" width="100%">
<p>General Support, Feedback and Escalation</a></strong><br>
For general support, feedback, and escalation of issues</p>
<p>
</a></p>
</td>
</tr>
</tbody>
</table>
<br>
<p>&nbsp;</p>
<p>&nbsp;</p>
</td>
</tr>
</tbody>
</table>
</div>
</body>
</html>








Here is the ConfigFile.xml Contents:

<?xml version="1.0" encoding="utf-8" ?>
<!-- ==============================================================================================
    Config File valid structure:
    <configuration>
    <property>...</property>
    ...
        <property>
            <item>...</item>
            <item>...</item>
            ...
        </property>
        ...
    </configuration>
=============================================================================================== -->
<configuration>
    <property name="ToolbarMode">ShowOnFocus</property>
    <property name="ToolsWidth">680px</property>
</configuration>


Please advice... This thing is happening in Edit mode of publishing page layout. Also this is only happening when the editor is in HTML mode.




0
Stanimir
Telerik team
answered on 08 Jul 2010, 10:01 AM
Hi Amit,

Thank you for the provided information. It looks like there is a problem with the way that RadEditor for MOSS handles the default MOSS editor Auto Correct functionality. Normally if properties such as AllowTextMarkup, AllowFonts, AllowTables etc. are set in the SharePoint designer (For example:<PublishingWebControls:RichHtmlField id="Content" FieldName="PublishingPageContent" AllowFonts="false"  runat="server"/>) and there is a problem with the content, RadEditor for MOSS pops up a confirmation dialog, which allows you to clean the content. In your case this feature of the control is not working properly.

I logged this in our bug-tracking system and I hope that we will be able to fix it for the next release, which is scheduled for the end of the next week.

You can follow the PITS Issue by its ID: 2630


All the best,
Stanimir
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
0
Amit
Top achievements
Rank 1
answered on 08 Jul 2010, 03:53 PM
Hi,

Thanks for the prompt reply. Right now is there any way , so that we can avoid this for the time being.
Actually we are using editor as a web part. please suggest so that for the time being we can proceed without having this issue.


Thanks
Amit
0
Stanimir
Telerik team
answered on 12 Jul 2010, 08:07 AM
Hi Amit,

Unfortunately the problem is in the server code of the control, so there is no easy way of fixing this issue. At this point you can try using the Strip formatting options of the editor http://www.telerik.com/help/aspnet-ajax/cleaningwordformatting%20.html or you need to stop the MOSS Auto Correct functionality of the control.


Kind regards,
Stanimir
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
0
Amit
Top achievements
Rank 1
answered on 12 Jul 2010, 10:34 AM
Hi There,

Thanks for the reply. How can we stop the Moss auto correct functionality? please let me know.

Thanks
Amit Kumar
0
Stanimir
Telerik team
answered on 13 Jul 2010, 07:51 AM
Hi Amit,
I found the following forum thread regarding this matter http://vspug.com/sezai/2007/10/19/locking-down-styles-in-the-moss-publishing-html-field-control/.

I think that you need to modify the PublishingWebControls:RichHtmlField filed in SharePoint designer (as it is explained in http://www.telerik.com/help/aspnet-ajax/using-radeditor-in-web-content-management-scenario.html) and remove properties such as AllowFonts, AllowExternalUrls etc.

Greetings,
Stanimir
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
0
Solomon
Top achievements
Rank 1
answered on 20 Oct 2010, 06:41 PM
Does anyone know if this has been resolved in the latest build? I cannot find 2630 in the PITS system and this issue is becoming a real pain to work around.

Thanks!

Solomon
0
Stanimir
Telerik team
answered on 21 Oct 2010, 08:10 AM
Hello Solomon,

At this point the only solution is to remove properties such as AllowFonts, AllowExternalUrls etc.


Best wishes,
Stanimir
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Tags
WebParts for SharePoint
Asked by
Amit
Top achievements
Rank 1
Answers by
Stanimir
Telerik team
Amit
Top achievements
Rank 1
Solomon
Top achievements
Rank 1
Share this question
or