system.webServer not recognized

6 posts, 0 answers
  1. Michael
    Michael avatar
    3 posts
    Member since:
    Jun 2013

    Posted 15 Oct 2013 Link to this post

    Whenever I try to F5/preview a site through visual studio, I get:

    Server Error in '/' Application.

    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. 

    Parser Error Message: Unrecognized configuration section system.webServer.

    Source Error: 

    Line 66:     <httpModules/>
    Line 67:   </system.web>
    Line 68:   <system.webServer>
    Line 69:     <modules runAllManagedModulesForAllRequests="true"/>
    Line 70:     <validation validateIntegratedModeConfiguration="false"/>

    That section has
    '<system.webServer>
        <modules runAllManagedModulesForAllRequests="true"/>
        <validation validateIntegratedModeConfiguration="false"/>
        <handlers>
          <remove name="ChartImage_axd"/>
          <remove name="Telerik_Web_UI_SpellCheckHandler_axd"/>
          <remove name="Telerik_Web_UI_DialogHandler_aspx"/>
          <remove name="Telerik_RadUploadProgressHandler_ashx"/>
          <remove name="Telerik_Web_UI_WebResource_axd"/>
          <add name="Telerik_Web_UI_WebResource_axd" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" verb="*" preCondition="integratedMode"/>
          <add name="ChartImage_axd" path="ChartImage.axd" type="Telerik.Web.UI.ChartHttpHandler" verb="*" preCondition="integratedMode"/>
          <add name="Telerik_Web_UI_SpellCheckHandler_axd" path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler" verb="*" preCondition="integratedMode"/>
          <add name="Telerik_Web_UI_DialogHandler_aspx" path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler" verb="*" preCondition="integratedMode"/>
          <add name="Telerik_RadUploadProgressHandler_ashx" path="Telerik.RadUploadProgressHandler.ashx" type="Telerik.Web.UI.RadUploadProgressHandler" verb="*" preCondition="integratedMode"/>
        </handlers>
      </system.webServer>'
    If I kill the system.WebServer section, it errors out that it can't find it. So it's looking for it, but it doesn't know what to do with it when it finds it. 

    No one else on my team has any problem with this. Any ideas what's wrong?
  2. Daniel
    Admin
    Daniel avatar
    4949 posts

    Posted 18 Oct 2013 Link to this post

    Hello Michael,

    Can you please post the contents of your web.config file here?

    Regards,
    Daniel
    Telerik
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to the blog feed now.
  3. Michael
    Michael avatar
    3 posts
    Member since:
    Jun 2013

    Posted 18 Oct 2013 Link to this post

    <?xml version="1.0"?>
    <configuration>
      <configSections>
      
      </configSections>
       
      <oas.web.log>
            <application name="X"/>
        </oas.web.log>
        <appSettings>
        XXX
        </appSettings>
        <system.web>
             
            <!--  DYNAMIC DEBUG COMPILATION
              Set compilation debug="true" to enable ASPX debugging.  Otherwise, setting this value to
              false will improve runtime performance of this application.
              Set compilation debug="true" to insert debugging symbols (.pdb information)
              into the compiled page. Because this creates a larger file that executes
              more slowly, you should set this value to true only when debugging and to
              false at all other times. For more information, refer to the documentation about
              debugging ASP.NET files.
        -->
            <compilation debug="true" defaultLanguage="c#" targetFramework="4.0">
            </compilation>
            <!--  CUSTOM ERROR MESSAGES
              Set customErrors mode="On" or "RemoteOnly" to enable custom error messages, "Off" to disable.
              Add <error> tags for each of the errors you want to handle.
     
              "On" Always display custom (friendly) messages.
              "Off" Always display detailed ASP.NET error information.
              "RemoteOnly" Display custom (friendly) messages only to users not running
               on the local Web server. This setting is recommended for security purposes, so
               that you do not display application detail information to remote clients.
        -->
            <!--<customErrors mode="On" defaultRedirect="~/SomethingsWrong.html"/>-->
            <!--  AUTHENTICATION
              This section sets the authentication policies of the application. Possible modes are "Windows",
              "Forms", "Passport" and "None"
     
              "None" No authentication is performed.
              "Windows" IIS performs authentication (Basic, Digest, or Integrated Windows) according to
               its settings for the application. Anonymous access must be disabled in IIS.
              "Forms" You provide a custom form (Web page) for users to enter their credentials, and then
               you authenticate them in your application. A user credential token is stored in a cookie.
              "Passport" Authentication is performed via a centralized authentication service provided
               by Microsoft that offers a single logon and core profile services for member sites.
        -->
            <authentication mode="Windows"/>
            <!--  AUTHORIZATION
              This section sets the authorization policies of the application. You can allow or deny access
              to application resources by user or role. Wildcards: "*" mean everyone, "?" means anonymous
              (unauthenticated) users.
        -->
            <authorization>
                <allow users="*"/>
                <!-- Allow all users -->
                <!--  <allow     users="[comma separated list of users]"
                                 roles="[comma separated list of roles]"/>
                      <deny      users="[comma separated list of users]"
                                 roles="[comma separated list of roles]"/>
                -->
            </authorization>
            <!--  APPLICATION-LEVEL TRACE LOGGING
              Application-level tracing enables trace log output for every page within an application.
              Set trace enabled="true" to enable application trace logging.  If pageOutput="true", the
              trace information will be displayed at the bottom of each page.  Otherwise, you can view the
              application trace log by browsing the "trace.axd" page from your web application
              root.
        -->
            <trace enabled="false" requestLimit="10" pageOutput="true" traceMode="SortByTime" localOnly="true"/>
            <!--  SESSION STATE SETTINGS
              By default ASP.NET uses cookies to identify which requests belong to a particular session.
              If cookies are not available, a session can be tracked by adding a session identifier to the URL.
              To disable cookies, set sessionState cookieless="true".
        -->
            <!--<sessionState mode="StateServer" stateConnectionString="tcpip=127.0.0.1:" sqlConnectionString="data source=127.0.0.1;Trusted_Connection=yes" cookieless="false" timeout="20"/>-->
            <sessionState mode="" sqlConnectionString="Server=;UID=;PWD=;Database=ASPState" cookieless="false" timeout="40" allowCustomSqlDatabase="true"/>
            <!--  GLOBALIZATION
              This section sets the globalization settings of the application.
        -->
            <globalization requestEncoding="utf-8" responseEncoding="utf-8"/>
            <xhtmlConformance mode="Legacy"/>
            <pages controlRenderingCompatibilityVersion="3.5" clientIDMode="AutoID"/>
        <httpHandlers>
          <add path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" verb="*" validate="false" />
        </httpHandlers>
      </system.web>
        <system.serviceModel>
            <bindings>
                <basicHttpBinding>
                    <binding name="MyBinding">
                        <security mode="TransportCredentialOnly">
                            <transport clientCredentialType="None"/>
                        </security>
                    </binding>
                </basicHttpBinding>
            </bindings>
            <behaviors>
                <serviceBehaviors>
                    <behavior name="">
                        <serviceMetadata httpGetEnabled="true"/>
                        <serviceDebug includeExceptionDetailInFaults="true"/>
                    </behavior>
                </serviceBehaviors>
            </behaviors>
            <services>
                <service behaviorConfiguration="" name="">
                    <endpoint address="" binding="basicHttpBinding" bindingConfiguration="MyBinding" name="BasicHttpEndpoint" contract="">
                        <identity>
                            <dns value="localhost"/>
                        </identity>
                    </endpoint>
                    <endpoint address="mex" binding="mexHttpBinding" contract="IMetadataExchange"/>
                </service>
            </services>
        </system.serviceModel>
      <system.webServer>
        <validation validateIntegratedModeConfiguration="false" />
        <handlers>
          <remove name="Telerik_Web_UI_WebResource_axd" />
          <add name="Telerik_Web_UI_WebResource_axd" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" />
        </handlers>
        <defaultDocument>
          <files>
            <add value="x.aspx" />
          </files>
        </defaultDocument>
      </system.webServer>
    </configuration>

  4. Daniel
    Admin
    Daniel avatar
    4949 posts

    Posted 18 Oct 2013 Link to this post

    Hello Michael,

    Could you please try removing the following line?
    <xhtmlConformance mode="Legacy"/>

    Regards,
    Daniel
    Telerik
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to the blog feed now.
  5. Michael
    Michael avatar
    3 posts
    Member since:
    Jun 2013

    Posted 18 Oct 2013 Link to this post

    Same error pointing back to system.webServer
  6. Daniel
    Admin
    Daniel avatar
    4949 posts

    Posted 23 Oct 2013 Link to this post

    Hello Michael,

    Everything else seems to be ok. This error may occur if some of the characters are in different encoding. I would recommend that you create a new web.config file from visual studio and then enter all the settings manually in it, by hand. If the problem still persist, please open a regular support ticket and provide a simple, runnable demo where the problem reproduces so we can debug it locally.

    Regards,
    Daniel
    Telerik
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to the blog feed now.
Back to Top