This is a migrated thread and some comments may be shown as answers.

Sys.WebForms is undefined

7 Answers 957 Views
Ajax
This is a migrated thread and some comments may be shown as answers.
Alexey
Top achievements
Rank 1
Alexey asked on 12 Feb 2009, 06:57 PM
Hi, i'm getting this error on this line (window[Sys.WebForms.PageRequestManager.getInstance()._uniqueIDToClientID(this._uniqueID)]=this;)
when use IIS for debugging
and at the same time  sys is not null, but WebForms is null

Moreover RadAjax.Net2 controls work fine, but Telerik.Web.UI don't. 

here is my sample
 
<asp:ScriptManager ID="ScriptManager" runat="server" /> 
 <telerik:RadAjaxManager EnableAJAX=true ID="RadAjaxManager1" runat="server"
</telerik:RadAjaxManager>  

my web config
<httpHandlers> 
            <remove path="*.asmx" verb="*"/> 
            <add path="*.asmx" verb="*" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" validate="false"/> 
            <add path="*_AppService.axd" verb="*" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" validate="false"/> 
            <add path="ScriptResource.axd" verb="GET,HEAD" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" validate="false"/> 
            <add path="Telerik.Web.UI.WebResource.axd" verb="*" type="Telerik.Web.UI.WebResource, Telerik.Web.UI, Version=2008.2.826.35, Culture=neutral, PublicKeyToken=121fae78165ba3d4" validate="false"/> 
        </httpHandlers> 
        <httpModules> 
            <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/> 
        </httpModules> 
 
 
<system.webServer> 
        <validation validateIntegratedModeConfiguration="false"/> 
        <modules> 
            <remove name="ScriptModule"/> 
            <add name="ScriptModule" preCondition="managedHandler" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/> 
        </modules> 
        <handlers> 
            <remove name="WebServiceHandlerFactory-Integrated"/> 
            <remove name="ScriptHandlerFactory"/> 
            <remove name="ScriptHandlerFactoryAppServices"/> 
            <remove name="ScriptResource"/> 
            <add name="ScriptHandlerFactory" verb="*" path="*.asmx" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/> 
            <add name="ScriptHandlerFactoryAppServices" verb="*" path="*_AppService.axd" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/> 
            <add name="ScriptResource" preCondition="integratedMode" verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/> 
            <remove name="Telerik.Web.UI.WebResource"/> 
            <add name="Telerik.Web.UI.WebResource" path="Telerik.Web.UI.WebResource.axd" verb="*" type="Telerik.Web.UI.WebResource, Telerik.Web.UI, Version=2008.2.826.35, Culture=neutral, PublicKeyToken=121fae78165ba3d4"/> 
 
        </handlers> 
    </system.webServer> 
environment

Visual Studio 2008
Microsoft.Net 3.5 sp1
Vista business sp1 IIS7
Telerik.Web.UI, Version=2008.2.826.35

Any ideas?



7 Answers, 1 is accepted

Sort by
0
SamJ
Top achievements
Rank 1
answered on 13 Feb 2009, 06:11 AM
Hi Alexey,

Try changing the ScriptManager ID to ScriptManeger1 instead of ScriptManager. Does it make any difference.
Additionally, do you have any client code on the problematic page? Can you paste it here?

Thanks,
SamJ
0
Michael Brading
Top achievements
Rank 1
answered on 13 Feb 2009, 10:51 AM
Thanks for your reply, but it didn't help. I think this problem mainly related to  IIS7 settings and .NET 3.5 SP1.
0
Iana Tsolova
Telerik team
answered on 16 Feb 2009, 12:53 PM
Hi Michael,

I suggest that you open a formal support ticket and send us a runnable sample illustrating the issue you are facing. Thus we could investigate it in depth locally and provide a proper solution to you.

Kind regards,
Iana
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Check out the tips for optimizing your support resource searches.
0
r00tsecurity
Top achievements
Rank 1
answered on 21 Apr 2009, 02:30 PM
Hi Alexey I have the same problem. How did you solve it?
0
Iana Tsolova
Telerik team
answered on 23 Apr 2009, 02:47 PM
Hi r00tsecurity,

Please try troubleshooting the mentioned error as suggested in the below online resources and see if it helps:

http://www.telerik.com/help/aspnet-ajax/troubleshooting.html
http://www.telerik.com/help/aspnet-ajax/web-resources-troubleshooting.html
http://www.telerik.com/help/aspnet-ajax/adding%20radcontrols%20prometheus%20to%20an%20existing%20application.html

Best wishes,
Iana
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Check out the tips for optimizing your support resource searches.
0
Matt
Top achievements
Rank 1
answered on 01 Feb 2011, 11:27 AM
Hello,

I experienced this problem after upgrading from Q1 2007 to Q3 2010. I fixed it by removing the following line from my web.config file;

<xhtmlConformance mode="Legacy" />

I hope this infomation helps someone else in the future.

Matt.
0
Joshua
Top achievements
Rank 1
answered on 02 Jul 2012, 03:47 PM
Here's a solution to this error if you're receiving it only on the iPad in full-screen mode.

The problem turned out to be related to a header the iPad was sending to ASP.Net.  I've outlined the solution here: http://joshmouch.wordpress.com/2012/07/02/sys-webforms-is-undefined-on-ipad/ 

Basically, you just have to tell ASP.Net that the iPad in full screen mode supports ajax.
protected override void OnPreInit(EventArgs e)
{
    if (Request.UserAgent != null && Request.UserAgent.IndexOf("AppleWebKit", StringComparison.CurrentCultureIgnoreCase) > -1)
    {
        this.ClientTarget = "uplevel";
    }
 
    base.OnPreInit(e);
}
Tags
Ajax
Asked by
Alexey
Top achievements
Rank 1
Answers by
SamJ
Top achievements
Rank 1
Michael Brading
Top achievements
Rank 1
Iana Tsolova
Telerik team
r00tsecurity
Top achievements
Rank 1
Matt
Top achievements
Rank 1
Joshua
Top achievements
Rank 1
Share this question
or