This is a migrated thread and some comments may be shown as answers.

Style problem

5 Answers 17 Views
Docking
This is a migrated thread and some comments may be shown as answers.
guo
Top achievements
Rank 1
guo asked on 11 Jan 2019, 09:08 AM

Hello,

when I selected the RadPane on the right,the pinbutton has missed.When I selected another control ,the pinbutton display.

How to change the pinbutton to solve the problem?

Regards,

Guo

5 Answers, 1 is accepted

Sort by
0
guo
Top achievements
Rank 1
answered on 14 Jan 2019, 01:47 AM
 How to rewrite the pinbutton on another way?
0
guo
Top achievements
Rank 1
answered on 14 Jan 2019, 10:31 AM

The 1.jpg is a part of the RadPaneGroupStyle code ,how can I change the  style of SelectedPane?

It maybe solve my problem.

0
guo
Top achievements
Rank 1
answered on 15 Jan 2019, 09:09 AM

The 1.jpg is the documents on the website,but I can not find the PaneHeader int my Blend.

How to solve this problem?

0
Accepted
Dinko
Telerik team
answered on 16 Jan 2019, 08:11 AM
Hello guo wei,

Thank you for the provided images.

To change the style of the selected pane you can extract and edit the default template of the RadPane. You can take a look at the Editing Control Templates help article which describes how you can get the default template of the controls.

Looking at the provided images, I can see that you are using different theme. I am assuming that you are using NoXAML binaries. Can you share which theme are you referencing in your project? Also, do you have a custom style for the panes? If yes, can you remove them and check again if this behavior is still reproducible?

Regards,
Dinko
Progress Telerik
Get quickly onboarded and successful with your Telerik and/or Kendo UI products with the Virtual Classroom free technical training, available to all active customers. Learn More.
0
guo
Top achievements
Rank 1
answered on 24 Jan 2019, 02:10 AM

Thanks for your answer。I have solved the problem。

I used XAML binaries and I referenced Office2016 in my project without a custom style for the panes.

I changed the XAML binaries to NoXAML binaries according to your answer,the problem was solved.

Regards,
Guo

Tags
Docking
Asked by
guo
Top achievements
Rank 1
Answers by
guo
Top achievements
Rank 1
Dinko
Telerik team
Share this question
or