StripFormattingOnPaste for span not working

2 posts, 0 answers
  1. Ranjeet
    Ranjeet avatar
    1 posts
    Member since:
    Sep 2012

    Posted 17 Sep 2012 Link to this post

    Hi all,
    i am working on telerik radeditor, i want to make copy paste event with strip formatting,
    i implement webpart of telerik rad editor, use StripFormattingOnPaste event to format the copy text, i use
    <telerik:RadEditor runat="server" ID="RadEditor1" Height="515" StripFormattingOnPaste="MsWord,Font,Span,Css,ConvertWordLists" ToolsFile="/_wpresources/RadEditorSharePoint/ToolMenu.xml">
     </telerik:RadEditor>

    using this it edit all the text with css, fonts,scripts, ms word tags, also span....but it not remove all span from copy contain.

    following is HTML format after Paste Text in editor but still one span is reaming..

    <h1><a name="_Toc335312925">1&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Heading&nbsp; 1</a></h1>
    <h2><a name="_Toc335312926">1.1&nbsp;&nbsp; Heading 2</a> </h2>
    <p><b>Bold</b><b> </b></p>
    <p><i>Italic</i></p>
    <p><span style="text-decoration: underline;">Underline</span></p>
    <p><sub>Sub</sub>script </p>
    <p><sup>Super</sup>script</p>
    <ol>
        <li>Ordered List 1</li>
        <li>Ordered List 2</li>
        <li>Ordered List 3</li>
    </ol>
    <p>&nbsp;</p>
    <ul>
        <li>Unordered List 1</li>
        <li>Unordered List 2</li>
    </ul>
    Unordered List 3
  2. Rumen
    Admin
    Rumen avatar
    14324 posts

    Posted 19 Sep 2012 Link to this post

    Hello,

    Try to disable the ConvertFontToSpan filter of RadEditor, which converts the font tags to span tags. If this does not help open a support ticket and provide an HTML page with the original content so that I can test it.

    Regards,
    Rumen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
Back to Top