This is a migrated thread and some comments may be shown as answers.

Spaces seem to be randomly removed in Editor telerik control

3 Answers 35 Views
Editor
This is a migrated thread and some comments may be shown as answers.
Shri
Top achievements
Rank 1
Shri asked on 25 Oct 2013, 12:08 PM
Hello Support,

we are having a problem with content pasted in (Editor). Spaces seem to be randomly removed.

The problem can be duplicated in your demos.

If I copy and paste the following text (which was copy/pasted from "http://simple.wikipedia.org/wiki/Paragraph"):

"A paragraph is a group of words put together to form a group that is usually longer than a sentence. Paragraphs are often made up of many sentences. They are usually between four to eight sentences. Paragraphs can begin with an indentation (about five spaces), or by missing a line out, and then starting again; this makes telling when one paragraph ends and another begins easier."

If I paste it into my editor (or the demo @ http://demos.telerik.com/aspnet-ajax/editor/examples/default/defaultcs.aspx) it randomly removes spaces, notably in my example between the words "many sentences" .  It turns to "manysentences

The editor on your demo asks me if I want to "clean word formatting".  If I say yes, the spacing problem exists."  

3 Answers, 1 is accepted

Sort by
0
Ianko
Telerik team
answered on 28 Oct 2013, 01:24 PM
Hello Shrikant,

I tried to reproduce the problem, but to no avail. Please find attached a clip, in which I am showing the mentioned steps with the online demo and everything seems to be working as expected.
 
Please review the material and let me know if I am missing something important that could lead to the problematic issue.

Regards,
Ianko
Telerik
If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to the blog feed now.
0
Shri
Top achievements
Rank 1
answered on 29 Oct 2013, 12:16 PM
Hello Ianko,

Thank you for quick response. The above problem occurs when you try to copy the paragraph from the "http://simple.wikipedia.org/wiki/Paragraph" & if the paragraph contains display in specific format (beacause of Monitor resolution) such as , after the "many" word line breaks in paragraph.

To clarify the steps please click on following link,
Steps to reproduce Issue 
0
Ianko
Telerik team
answered on 31 Oct 2013, 12:24 PM
Hello Shrikant,

Thank you for the screencast. I reproduced the problem, but it is more related to a problem with this specific content and it is also reproducible with a simple editable iframe element. In the attached clip you can see that in the copied content there should be an $nbsp; entity, which is missing after zooming the specific test. 

Due to the reason that this is not a problem related to the editor's implementation we are unable to provide a workaround or fix such issue. 

Regards,
Ianko
Telerik
If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to the blog feed now.
Tags
Editor
Asked by
Shri
Top achievements
Rank 1
Answers by
Ianko
Telerik team
Shri
Top achievements
Rank 1
Share this question
or