This is a migrated thread and some comments may be shown as answers.

SmartTag is disabled

1 Answer 62 Views
Editor
This is a migrated thread and some comments may be shown as answers.
Timothy DiPaula
Top achievements
Rank 1
Timothy DiPaula asked on 18 May 2010, 02:18 PM
I have a RadEditor in the user control of a SharePoint 2010 Visual Webpart in Visual Studio 2010.  The Show SmartTag option is disabled when I right click the control in design view.  I would like access to the SmartTag so I can add the required entries in the web.config for the HttpHandler to use the SpellCheck and ImageManager.  I tried adding the entries manually but continue to get an error message saying that I need to add the handlers to the web.config.

1 Answer, 1 is accepted

Sort by
0
Timothy DiPaula
Top achievements
Rank 1
answered on 19 May 2010, 04:30 PM
To utilize RadSpell and the Image Manager dialogs in SharePoint 2010 you should do the following:

In the <handlers> element of the web.config:

 

<add name="RadSpell" verb="*" path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler, Telerik.Web.UI" />

<add name="RadDailog" verb="*" path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler" />

 

Also add these with the other location elements:

 

<location path="~/Telerik.Web.UI.DialogHandler.axd">

    <system.web>

      <authorization>

        <allow users="*" />

      </authorization>

    </system.web>

  </location>

  <location path="Telerik.Web.UI.SpellCheckHandler.axd">

    <system.web>

      <authorization>

        <allow users="*" />

      </authorization>

    </system.web>

  </location>

  <location path="Telerik.Web.UI.WebResource.axd">

    <system.web>

      <authorization>

        <allow users="*" />

      </authorization>

    </system.web>

  </location>

 

Copy the RadSpell folder from C:\Program Files (x86)\Telerik\RadControls for ASP.NET AJAX Q1 2010\App_Data to C:\inetpub\wwwroot\wss\VirtualDirectories\80\App_Data

Copy the Telerik.Web.UI dll into the C:\inetpub\wwwroot\wss\VirtualDirectories\80\bin folder.

Copy the Telerik.Web.UI dll into the C:\inetpub\wwwroot\wss\VirtualDirectories\80\_app_bin folder.

Change the RadEditor's setting for the DialogHanderlUrl to "/_layouts/Telerik.Web.UI.DialogHandler.aspx" 


Tags
Editor
Asked by
Timothy DiPaula
Top achievements
Rank 1
Answers by
Timothy DiPaula
Top achievements
Rank 1
Share this question
or