This is a migrated thread and some comments may be shown as answers.

Slow performance

2 Answers 187 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Bhakti
Top achievements
Rank 1
Bhakti asked on 14 Jun 2012, 02:42 PM
Few users are having our WPF telerik application  running very slow. This is when its loads and switch between tabs etc. All tabs have radgrids. It just says not responding and hangs.
But it works very welll on others. 
Do you have any clue?

2 Answers, 1 is accepted

Sort by
0
Dimitrina
Telerik team
answered on 14 Jun 2012, 05:16 PM
Hi,

As I understand you have placed the RadGridView inside a RadTabControl. Is that correct?

May I ask you if you have specified a value for the IsContentPreserved property for the RadTabControl? What is the result if you set set it to True?

Greetings,
Didie
the Telerik team

Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

0
Mike
Top achievements
Rank 1
answered on 02 Jul 2012, 04:43 PM
Hello,

I have a very similar scenario with similar performance problem. Not sure if this is related but just in case:

After spending a good few hours on this my problem was related to a .NET 4.0 bug relating to UI automation. This cause deep recursive calls to UIElementHelper.InvalidateAutomationAncestors. You can find more info here: http://social.msdn.microsoft.com/Forums/en/windowsaccessibilityandautomation/thread/6c4465e2-207c-4277-a67f-e0f55eff0110 

In my case Roboform was the ui automation service trying to access my WPF app but it could be others like tablet input services etc.

Hope this helps.

Mike
Tags
General Discussions
Asked by
Bhakti
Top achievements
Rank 1
Answers by
Dimitrina
Telerik team
Mike
Top achievements
Rank 1
Share this question
or