Slight transparent border around chart image

Thread is closed for posting
2 posts, 0 answers
  1. Peter
    Peter avatar
    4 posts
    Member since:
    Jun 2012

    Posted 23 Jul 2012 Link to this post

    Hi all,

    I want to combine a chart image with two tabs above it (simple div tags) but there is always some space between my tab divs and the chart image. I have set the following properties for the chart:

    radChart1.Appearance.Border.Visible = false;
    radChart1.PlotArea.Appearance.Border.Visible = false;
    radChart1.PlotArea.Appearance.Dimensions.Margins = new ChartMargins(0, 0, 0, 0);
    radChart1.Chart.Appearance.Border.Visible = false; //I guess this is the same as radChart1.Appearance etc.

    When I save the chart image and view it in Photoshop there is clearly a  transparent area around the image containing a slight shadow. This causes the space between my tabs and the chart. How can I remove that? The skin I use for the chart is 'DeepBlue'.

    Oh, and I have seen the project but that also creates a small transparent area around the chart.



  2. Petar Marchev
    Petar Marchev avatar
    996 posts

    Posted 26 Jul 2012 Link to this post

    Hi Peter,

    May be I did not understand very well what your problem is, because the following should work just fine:

    <telerik:RadChart runat="server" ID="RadChart1" AutoLayout="false" >
      <Appearance Dimensions-Margins="0" />

    Give it a try anyway, instead of the C# code you provided. I have attached an image of the output that I get with and without this setting. Let us know if this is the spacing that you are talking about. If you need further assistance I will ask that you provide us with a couple of snapshots of what you currently have and what are the results that you are after. 

    All the best,
    Petar Marchev
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
Back to Top