Sitecore Rich Text editor adds font-size="14" applying css class (IE8)

6 posts, 0 answers
  1. Paul
    Paul avatar
    2 posts
    Member since:
    Jan 2011

    Posted 21 Jan 2011 Link to this post

    Hi,

    This doesn't happen with Firefox, and apparently not with IE7, but in IE8 when applying a css class from the 'apply css class' drop down list, the editor also adds FONT-SIZE="14" which slightly defeats the purpose of using classes to manage styles.

    Is there a solution or work-around to this? This is using Sitecore 6.3

  2. Paul
    Paul avatar
    2 posts
    Member since:
    Jan 2011

    Posted 24 Jan 2011 Link to this post

    Solution here : http://www.telerik.com/community/forums/aspnet/editor/how-do-i-avoid-having-font-size-14pt-in-my-markup.aspx
  3. Christian
    Christian avatar
    1 posts
    Member since:
    Jul 2011

    Posted 21 Jul 2011 Link to this post

    That isn't a solution unfortunately, as that just converts the spans into in <font> tags, which is even worse (as <font> is more or less deprecated).

    There seems to have been issues with something similar to this since 2005:

    http://www.telerik.com/community/forums/aspnet/editor/how-do-i-avoid-having-font-size-14pt-in-my-markup.aspx
    And the only reply has been to switch the ConvertFontToSpan value from true to false or the other way around, which isn't really a fix.

    Can't there be done something about this soon, we've been asking Sitecore for a solution since 2009 and they said then, they are waiting for you to fix it.

    - Christian Willumsen
  4. Dobromir
    Admin
    Dobromir avatar
    1633 posts

    Posted 25 Jul 2011 Link to this post

    Hi Christian,

    Please note that Sitecore CMS 6.3 is using RadEditor for ASP.NET (RadEditor Classic), which development is discontinued for more than two years in favor for the RadEditor for ASP.NET AJAX. In the release notes of of Sitecore CSM i noticed that in version 6.4 they have replaced RadEditor Classic with RadEditor for ASP.NET AJAX.

    Do you experience the same problem with RadEditor for ASP.NET AJAX? Are you able to reproduce it on the live demos?

    Regards,
    Dobromir
    the Telerik team

    Register for the Q2 2011 What's New Webinar Week. Mark your calendar for the week starting July 18th and book your seat for a walk through of all the exciting stuff we will ship with the new release!

  5. Dennis
    Dennis avatar
    38 posts
    Member since:
    Aug 2010

    Posted 05 Dec 2011 Link to this post

    When radgrid is in dissable state. we are not able to see the text in it.
    I want to make the text more visible.
    which css property should i set to get text in black.
    (i.e. I want to increase opacity of text in grid when it is in dissable state)
    plz help
  6. Rumen
    Admin
    Rumen avatar
    14431 posts

    Posted 06 Dec 2011 Link to this post

    Hello David,

    Could you please provide a screenshot of the problem and a live URL to the problematic site?

    Have you tried by any chance to examine which CSS styles are causing the problem using Firebug or IE Dev toolbar and to override them?


    Kind regards,
    Rumen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now
Back to Top