This is a migrated thread and some comments may be shown as answers.

Scheduler in day mode, shows overlapping boxes, where the times do not overlap

2 Answers 35 Views
Scheduler
This is a migrated thread and some comments may be shown as answers.
ash
Top achievements
Rank 1
ash asked on 03 Nov 2015, 04:31 PM

Hi there, it seems that when the scheduler is given times that overlap on the 1/2 hour, it extends that box up until the next half hour mark. This causes the component to show appointments which "appear" to overlap, even though they do not.

Please see screen attached below

First appointment goes until 09:31, second appointment starts 09:32

However the component shows overlap (highlighted in red box), because the first appointment box has been extended up until the 10:00 half hour mark.

Is there anything that can be done about this, are there any settings which would allow for a more accurate representation of the timings?

http://i.imgur.com/XzTrRET.png

thanks.

ash

2 Answers, 1 is accepted

Sort by
0
Accepted
Bozhidar
Telerik team
answered on 04 Nov 2015, 09:05 AM
Hi,

There is such a property - EnableExactTimeRendering. You have to set it to true for the view you are using. For instance:
<telerik:RadScheduler runat="server" ID="RadScheduler1"
    SelectedView="WeekView">
    <WeekView EnableExactTimeRendering="true" />
</telerik:RadScheduler>


Regards,
Bozhidar
Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
0
ash
Top achievements
Rank 1
answered on 04 Nov 2015, 09:27 AM

Thank you sir, I added the property for DayView and WeekView and now it displays just as I needed :)

Legendary.

Tags
Scheduler
Asked by
ash
Top achievements
Rank 1
Answers by
Bozhidar
Telerik team
ash
Top achievements
Rank 1
Share this question
or