This is a migrated thread and some comments may be shown as answers.

RTL in radgrid dont work

10 Answers 71 Views
Grid
This is a migrated thread and some comments may be shown as answers.
Rasin Vadim
Top achievements
Rank 1
Rasin Vadim asked on 22 Jul 2008, 08:30 AM
Hi telerik team.

Following the instructions i have found in the rtl demo... When i try to implament the solution and set my in my mastertableview dir=rtl the output and the whole behavior of the grid completely ignores the scenerio that says:

RadGrid supports right-to-left presentation. You merely need to set the Dir property for the MasterTableView/GridTableViews to "RTL".

RadGrid renders RadGridRTL_SkinName class when placed in element with dir set to "rtl". This further facilitates skinning RadGrid and providing RTL specific settings.

My problem is that when i view the source of my page i cannot find anywhere in my html that the grid is using the RadGridRTL_SkinName! its seems that control simply ignores this statement. 

Even viewing the html source of the demo listed above, there is no place that RadGridRTL_SkinName  class comes to use.

Please check this bug and get back to me.

Thanks,
Rasin Vadim.

10 Answers, 1 is accepted

Sort by
0
Dimo
Telerik team
answered on 22 Jul 2008, 04:15 PM
Hi Rasin Vadim,

Indeed, there seems to be a problem with the RTL CSS class. We will research and fix it. I have updated your Telerik points for bringing the issue to our attention.

Greetings,
Dimo
the Telerik team

Instantly find answers to your questions at the new Telerik Support Center
0
Rasin Vadim
Top achievements
Rank 1
answered on 22 Jul 2008, 06:17 PM
Thank you dimo.

Please let me know when this issue will be resolved since this feature is very crucuial to my current project because i want to fully localize the grid control.

Thanks,
Rasin Vadim.
0
Dimo
Telerik team
answered on 23 Jul 2008, 07:43 AM
Hi Rasin Vadim,

I am glad to inform you that this bug is now fixed and changes will take effect in the coming Q2 2008 release, which will be uploaded on our website shortly.

All the best,
Dimo
the Telerik team

Instantly find answers to your questions at the new Telerik Support Center
0
Rasin Vadim
Top achievements
Rank 1
answered on 27 Jul 2008, 02:28 PM
Hi dimo.

I am very disappointed to inform you that this bug still exists...

Have you at least test it before you released the new version?

Please have a look on the html source of:
http://www.telerik.com/DEMOS/ASPNET/Prometheus/Grid/Examples/Styles/RightToLeft/DefaultCS.aspx

you can see that your currently version simply don't render the RadGridRTL_SkinName as you say its supposed to.

Rasin Vadim.
0
Vladimir
Top achievements
Rank 1
answered on 27 Jul 2008, 02:59 PM
Rasin,

The class is applied client-side - you can use FireBug to check this.

Vlad
0
Rasin Vadim
Top achievements
Rank 1
answered on 05 Aug 2008, 07:57 AM
Hi vlad.

thanks for your reply. I've tested it and its not applied in the client side. I am viewing the grid in IE7.

I will open support ticket and submit my solution so telerik team will tell me what i was doing wrong.

Thanks,
Rasin Vadim.
0
Rasin Vadim
Top achievements
Rank 1
answered on 27 Aug 2008, 01:54 PM
After a lot of testing and reading i've come to the conclution that the rtl support of the radgrid is bad.

All who wish to localize their grid should use their own skin and work with two diffrents css documents: 

Head Tag Format: 

<

head runat="server">

<title></title>

<link runat="server" id="linkGeneral" rel="stylesheet" type="text/css" />

<link runat="server" id="linkLanguage" rel="stylesheet" type="text/css" />

<link runat="server" id="linkCommon" rel="stylesheet" type="text/css" />

<link runat="server" id="linkGrid" rel="stylesheet" type="text/css" />

<meta http-equiv="Content-Script-Type" content="text/javascript" />

<meta http-equiv="Content-Style-Type" content="text/css" />

<script language="JavaScript" type="text/javascript" src="js/generalScripts.js"></script>

<script language="JavaScript" type="text/javascript" src="js/tooltip.js"></script>

</

head>


Page_Load:

this

.linkGrid.Href="~/Skins/MySkin/Grid.MySkin.ltr.css";

this.linkGrid.Href="~/Skins/MySkin/Grid.MySkin.rtl.css";

Vadim Rasin.

0
Dimo
Telerik team
answered on 27 Aug 2008, 03:28 PM
Hello Rasin,

We will be glad if you be more specific and share with us what should be changed in the RadGrid control, so that it works better in RTL mode.

Sincerely yours,
Dimo
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
0
Rasin Vadim
Top achievements
Rank 1
answered on 01 Sep 2008, 06:02 AM

Hi dimo.

In my opinion the best localization support telerik can offer is that it will have its css & images inside rtl & ltr folders and file names.

For example the hierarchy of the skin folders should be something like this:
Skins\Grid\Vista\ltr\Grid.Vista.css
Skins\Grid\Vista\rtl\Grid.Vista.css
The appropriate control should know what css to load according to its thread's culture. If the appropriate control has been implicitly set to 'rtl' mode then it should override the culture settings. (as the mastertableview.dir = rtl in the grid control)
I think this way developers will be able to fully localize telerik controls and images and no client side configuration will be needed to apply for the grid control since it comes as rtl only.

I think the approach above should be implemented for all telerik controls.

Thanks in advance.
Vadim Rasin.

0
Dimo
Telerik team
answered on 01 Sep 2008, 07:15 AM
Hello Vadim Rasin,

Thank you for your suggestion, we will think about it.

Sincerely yours,
Dimo
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Tags
Grid
Asked by
Rasin Vadim
Top achievements
Rank 1
Answers by
Dimo
Telerik team
Rasin Vadim
Top achievements
Rank 1
Vladimir
Top achievements
Rank 1
Share this question
or