Required Assembly is Missing

3 posts, 0 answers
  1. f
    f avatar
    3 posts
    Member since:
    May 2011

    Posted 01 Dec 2011 Link to this post

    After I publish a WPF application and then try to install it . . . I get the following error:

    Unable to install or run the application. The application requires that assembly Telerik.Windows.Data Version 2010.2.924.40 be installed in the Global Assembly Cache (GAC) first.

    I am using Version 2010.3.1314.40 . . . so I am not sure why an earlier version is required. In the properties of Telerik.Windows.Data,
    Copy Local is set to true. So if this copies the assembly to the client machine that I assume this should resolve the issue, but it has not.

    I have attached an image of the full properties of Telerik.Windows.Data.

    Please help if you have any ideas.

    Thanks.

  2. Kellie
    Kellie avatar
    6 posts
    Member since:
    Oct 2011

    Posted 11 Jan 2012 Link to this post

    I have the same problem.
  3. Kellie
    Kellie avatar
    6 posts
    Member since:
    Oct 2011

    Posted 12 Jan 2012 Link to this post

    My problem is resolved now.

    One of my projects in the deployment had just one of the telerik dll references pointing to a folder outside of our "Shared Libraries" solution folder. Once this was fixed, the deployment was successful.

    It's weird because it caused all of these Telerik version errors.. and was a bit misleading.




    Kellie Harrisson
    Sierra Systems
Back to Top