Report Designer Stopped Working After Update-Database Code First EF

4 posts, 0 answers
  1. Jason
    Jason avatar
    2 posts
    Member since:
    Jan 2013

    Posted 14 Jul 2014 Link to this post

    Report Designer stopped working after adding 2 db fields.
    Can neither Preview Data in Existing Reports, or Design New Reports,  

    Fortuneately Production still works.
      I did clean build, add-migration & update-database successfully, clean build;
      Copied (2) project dll's from Bin to ReportDesigner folder (overwrote last ones).
      EntityFramework.dll already there - unchanged.
      Telerik.ReportDesigner.exe.config - left unchanged

    I even hand added (into .trdx text file) one of the new entity class fields to appear in an existing trdx report, it worked in production.
      At a standstill with Telerik Report Designer

    Preview Data gets msg - Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.  On ALL Existing reports, same msg.

    Incidentally, Telerik.Reporting & Telerik.Reporting.Services.WebApi are Q3 2013
    Have from Jan 2013-2014 DevCraft Ultimate Bundle - [I know, need to resubscribe]

    Have learned a ton following many Telerik Documentation, Tutorial & Blog posts.

    Using VSO to checkin & autobuild into Azure-Web (with Azure-SQL [dev & prod db same right now, I know not good, but helps in this issue])
    Running Visual Studio 2012.  MVC5, EF5. - [I know, need to upgrade]

    Tried attaching VS Debugger to Telerik.ReportDesigner.exe process - couldn't get it to trap error when Designer displays it.
    Tried Assembly Binding Log Viewer, wouldn't show anything.
    Tried on a second workstation - same issue.... - havent tried a new workstation from scratch.
    How can we trap that error.

    Editing existing reports, the New fields do show up in Data Explorer ok.  E.g. fPhone1, fPhone2;
      however, click preview, get error

    2nd Problem, Try to Create New Report, when choosing context, dropdown never gets populated, stays blank?
    looked @ both AppData\..\Telerik..\user.config & Telerik.ReportDesigner.exe.config for anything out the ordinary.  Seemed ok.

    Is there another way we can trap the error better
  2. KS
    KS avatar
    165 posts
    Member since:
    Oct 2012

    Posted 17 Jul 2014 in reply to Jason Link to this post


    Looks like EF has mixed assemblies. Update the references in the project... or subscribe for the Report.Error event, or debug the first VS instance with another one (the exception will be displayed in the second instance on design preview).

  3. Jason
    Jason avatar
    2 posts
    Member since:
    Jan 2013

    Posted 31 Jul 2014 in reply to KS Link to this post

    Hi KS, thanks for your help.
    Good ideas.
    1. I did not try subscribe for the Report.Error event, its not yet during execution of the app
    2. I did Debug StandaloneReportWriter from another VS Instance, and it reveals, series of:

    Failed to load function from MethodInfo RegisterBundles in type Local138Stage3.BundleConfig with error:
    System.IO.FileNotFoundException: Could not load file or assembly 'System.Web.Optimization, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.
    File name: 'System.Web.Optimization, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35'
    at System.Signature.GetSignature(Void* pCorSig, Int32 cCorSig, RuntimeFieldHandleInternal fieldHandle, IRuntimeMethodInfo methodHandle, RuntimeType declaringType)
    at System.Reflection.RuntimeMethodInfo.get_ReturnType()
    at Telerik.Reporting.Expressions.FunctionLoader.IsValid(MethodInfo methodInfo)
    at Telerik.Reporting.Expressions.FunctionLoader.<GetFunctions>d__1.MoveNext()

    with many more,
    Apologize in advance how to Update the references in the project - should I remove then re-add each one.
    In this first case, when i go to see if System.Web.Optimization is listed(Checked) in references, its listed in my references, but not listed in References (rightclick) > Add Reference... > Framworks or Extensions; it is in NuGet package manager, with Uninstall button - should i go top to bottom, or is there an smarter way.  Sorry to stray from your original guidance, which has me in the right direction.  Thanks for your help.
  4. Stef
    Stef avatar
    3611 posts

    Posted 05 Aug 2014 Link to this post

    Hi Jason,

    All assemblies added after installing the Nuget packages will be added to the VS project with the data model. Please test to update all assemblies in the Standalone Designer folder by copying them from the Bin folder of the project through which the data model is built into a DLL.

    This will ensure all dependent assemblies are available on starting the report designer tool, and they will be loaded.

    Let us know if you need any further help.


    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

Back to Top