This is a migrated thread and some comments may be shown as answers.

ReferenceError on Grid with ClientTemplate and Adding Row

1 Answer 9 Views
Grid
This is a migrated thread and some comments may be shown as answers.
GCS
Top achievements
Rank 1
GCS asked on 05 Mar 2014, 04:42 PM
This is a strange problem. I have a grid (code below) that contains a templated column for a drop-down control.  Whenever I run the site via an ip address I get the error.  However, when I access the site with a proper domain (eg, rep.ngkflocal.com), it functions fine. 

For instance, when accessed via the following URL: http://72.73.307.275/Plan/Edit/1342
The following error occurs: Uncaught ReferenceError: CapitalExpenditureType is not defined

However, when accessed like this via my local IIS web app: http://reppublish.ngkflocal.com/Plan/Edit/1342
I do not get the error, adding the row works fine. 

Both point to the same files. Any ideas? 


1 Answer, 1 is accepted

Sort by
0
Alexander Popov
Telerik team
answered on 07 Mar 2014, 12:33 PM
Hi Dave,

This looks like a file reference issue, although I cannot say for sure based on the error message only. Could you please share all related files? This would help us pinpoint the exact reason for this behavior and advise you further.

Regards,
Alexander Popov
Telerik
Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
Tags
Grid
Asked by
GCS
Top achievements
Rank 1
Answers by
Alexander Popov
Telerik team
Share this question
or