RadUpload always return false while validation of 4 char file extension!

Thread is closed for posting
2 posts, 1 answers
  1. Ahmed
    Ahmed avatar
    9 posts
    Member since:
    Jan 2011

    Posted 05 Jan 2011 Link to this post

    I use the following code for RadUpload control

    <telerik:RadUpload ID="rdUploadCertificate" CssClass="rad-upload" runat="server" ControlObjectsVisibility="ClearButtons" AllowedFileExtensions=".doc, .docx" InitialFileInputsCount="1" MaxFileInputsCount="1"></telerik:RadUpload>

    But while uploading a docx files, extension validation return false. I've tried it also for .xlsx.

    I use the following code to validate file extension

    return $find('<%= rdUploadCertificate.ClientID %>').validateExtensions();

    Am I missing anything?

  2. Answer
    Shinu avatar
    17764 posts
    Member since:
    Mar 2007

    Posted 05 Jan 2011 Link to this post


    I also replicated same only when there is extra space in specifying AllowedFileExtensions values like:
                      AllowedFileExtensions=".doc, .docx"

    And the following mark-up worked well for me. Try this code and see whether that helps.
    <telerik:RadUpload ID="rdUploadCertificate" CssClass="rad-upload" runat="server"
        ControlObjectsVisibility="ClearButtons" AllowedFileExtensions=".doc,.docx" InitialFileInputsCount="1" MaxFileInputsCount="1">

Back to Top